TechSpot

Neeed help urgently, ASUS K8V SE Deluxe

By makubexxx
Sep 8, 2005
Topic Status:
Not open for further replies.
  1. Hi, im a n00b to building systems and, as i expected, have messed up somewhere along the line!

    I have an Asus K8V deluxe
    3400+ athlon 64
    512mb DDR 3200 400mhz Ram (budget)
    40 gig ATA hard drive
    nvidia 6200 gfx
    NEC 4x dvd re/writer
    ATX full size case with 350watt PSU (bought with installed PSU)

    Ive put it together as best i could and am not mentally disabled so i know how to follow colour code etc.

    To my knowledge it is all installed correctly, but when i press the power switch on the front it just doesnt turn on! The mobo light is on inside the case, so the power is running through it, but it just wont turn on! Ive tried plugging the power switch into the reset switch and vice versa, ive checked the CPU fan is in the right socket, ive checked everything!... but it just wont turn on :-(
    The mobo is used and i got it off of ebay, and it has been tested working before dispatched to me.
    The case with PSU is a budget one from ebuyer, with temperate LCD at the front.
    The processor was bought OEM from novatech, and im sure ive installed it correctly.

    Any ideas please? im very appreciative! I start my IT btec national course at college next week and ive nothing to do work on at home!

    Thanks in advance
  2. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 1,382

    Hello! Welcome to TechSpot

    This will help in trouble shooting.
    Don't give up!
    Post back & G'Luck
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.