Network over internet, File sharing, Problem.

By mokaboy
May 20, 2007
Topic Status:
Not open for further replies.
  1. Hello all,

    i use a program called Hamachi between me and a mate. The program basically enables a virtual lan over the internet. We play games such as cnc3 over it its really gd! The only problem is we also want to be able to share files etc, i know how to set up networks but this is just refusing to work on my side.

    After loggin onto hamachi etc all thats left to do is set user permissions/file access to the files we want to share.

    If you have guest enabled you can view the shared files no probs on both of our computers but we want extra security and need passwords.

    Basically i set up on his computer a seperate login for me to use (moka) and set the permissions on the folder to share (took away everyone and just added moka), also added a password. When i connect to his computer the login screen comes up i type in the details and im in, done.

    But when he connects to me the login screen does not appear. I have done everything i can think of, its set up the same way, but instead of displaying a login screen so he can type in details of his account on my pc it just shows cannot access, file permission etc (sry cannot remember exactly).

    We can both ping each other fine, play games fine, share files under guest account with no password fine.

    Its not to do with the hamachi program itself rather windows (obviously), just where !!

    Please can some network wizard share his knowledge and tell me whats probably wrong?

    Ive tried to explain the situation as best i can, any more info needed tell us!
  2. tipstir

    tipstir TS Ambassador Posts: 4,487   +73

    VLAN connection working but file sharing is not?

    Are you using XP Pro and if so did you go into My Computer and select Tools then Folder Options. then View, scroll down to the bottom and make sure
    : Use simple file sharing (Recommended) is checked.. then click on apply
  3. Peerob

    Peerob Newcomer, in training Posts: 68

    sorry wrong post
  4. mokaboy

    mokaboy Newcomer, in training Topic Starter Posts: 251

    windows xp pro

    simple file sharing is off (i need it off)

    the shared folder has permissions for the account i made for mi mate
    when he trys to connect (browse) my computer it doesnt come up with a login just you do not have access.
  5. jobeard

    jobeard TS Ambassador Posts: 13,026   +221

    Can do!

    It would be advisable to create a NEW USER (with admin rights) which has
    a goofy login (eg zGamers) and use this account to set the Guest Password
    as follows:

    Login using an admin account and go to cp->User Account
    enable Guest account
    then change the password to something really unique
    then disable the User Account (disable only stop keyboard login!)​
    set Simple File Sharing
    allow File Sharing in your firewall
    and make sure you both have the same WORKGROUP NAME (eg gamers?)

    The remote user will see your system under
    View Entire Network->workgroups->your system name​
    when the system name is clicked, the prompt will appear for User/Password
    enter the Admin Login used to set the password and then the new Guest Password.
  6. mokaboy

    mokaboy Newcomer, in training Topic Starter Posts: 251

    i logged in as admin, went to user accounts, enabled guest but theres no option to change password... or even add a password.

    and surely if the guest account was disabled, when someone attempted a connect it would prompt the user for login?
  7. jobeard

    jobeard TS Ambassador Posts: 13,026   +221

    enable Simple File Sharing first
  8. mokaboy

    mokaboy Newcomer, in training Topic Starter Posts: 251

    did that, no luck :(

    There is no option to create or change a password when you enable the guest account with or without simple file sharing.

    update**

    What am i doing wrong :( the only person in the file permission is mi mates account, in the security tab theres all of em apart from everyone.

    anyone??? please
  9. jobeard

    jobeard TS Ambassador Posts: 13,026   +221

    yes there is -- see attachment.

    the alernative means to set the guest password (from an admin accnt) is:
    first ENABLE the guest account as normal, then launch
    run->cmd /k control userpasswords2 ​
    select the Guest account and set the pw :)

    be sure to revert Guest to Disabled when you're done.
  10. mokaboy

    mokaboy Newcomer, in training Topic Starter Posts: 251

    :) cheers, ill test it all tnite... guest thing now has password !
  11. mokaboy

    mokaboy Newcomer, in training Topic Starter Posts: 251

    can someone answer the question as to why when my mate trys to logon remotely theres no password screen? I have not tested what joebeard has suggested yet so that might be a fix. Im just wondering why it would not ask you for a password at all, just lock you out?
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.