Networking with crossovercable, FileSharing works, ICS doesn't

By bluef0x
Nov 10, 2005
  1. Hello all, first post here and hopefully you guys can help me out...

    I'm trying to network my laptop, my main computer is the one with the internet connection. I used network sharing wizard and it did nothing, so I manually set the laptop's ip address to and I can now share files, but internet still isn't shared. It says it's shared on the main computer.. I have a broadband connection.

    What should I try to do?
  2. Sharam

    Sharam TS Rookie Posts: 509

    The best thing you can do is to give us more detail.

    You need 2 NICs in your computer one with straight through cable to your high speed "modem" and a cross over to your laptop. With Internet ON, run the Wizard again. You can have USB to Ethernet, (it makes it much easier if you provide more info)

    You can use 2 wireless adapters they work in Ad-Hoc mode.

    Your best bet is to get a wireless or wired router from your local News Group or even best buy.

    We don't know much about your hardware and/ or software, sounds like you are running windows, tell us about your setup so we can help you better.
  3. bluef0x

    bluef0x TS Rookie Topic Starter

    I'm running Windows XP on both computers, the network works because I can share files but for some reason internet won't work on the laptop. I have two NIC's in the main computer with a crossover in the non-internet one to the laptop. The internet used to work a few months ago via this setup but not sure what happened, maybe a virus or something? Is there an DNS/gateway I need to assign to the NIC in the laptop? Because I had to manually assign it, the network wizard gave it a weird IP address.
  4. kirock

    kirock TS Rookie Posts: 1,221

    Your LAN NIC on main PC should be set to, your Laptop NIC should be set to "Automatically obtain IP". Turn off XP Firewall on Laptop. Both computers should be in the same workgroup. Also turn off all other protocols for the internet NIC except TCP/IP, (for security).
  5. Sharam

    Sharam TS Rookie Posts: 509

    Any other detail you forgot to mention?

    May be it would be easier to remove ICS then delete all your local area connections and start over.
  6. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    I use router with switching
    heres a link that might help
    network bridge
  7. bluef0x

    bluef0x TS Rookie Topic Starter

    When I set the laptop to obtain Ip address automatically it assigns it an ip of 169.254.x.x and I lose the ability to share files.
  8. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    go into firewall setting and allow for that ip address
    if you are using xp pro disable simple file sharing
    heres link to microsoft firewall settings
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...