new beta driver for Creative Sound Blaster X-Fi. Anyone Tried It?

By Ruben
Jun 11, 2006
Topic Status:
Not open for further replies.
  1. I have recently came across a new beta for X-Fi.
    Did anyone try it already? Does it work fine?
    I don't want to mess up my new rig with some bad drivers so asking this in advance...

    For anyone interested :
    here is the link and list of fixes:
    new X-Fi beta driver

    "This download is a beta driver for Creative Sound Blaster® X-Fi. It is not fully tested. This download provides full OpenAL 1.1 support for gamers. For more details, read the rest of this web release note.

    Take note of the following:
    THIS IS AN UNSUPPORTED BETA DRIVER. There is no technical support for this driver.
    We recommend that only experienced users install this driver. Do not install this driver for critical tasks. Users who are looking for stable drivers should wait for the final release.
    This beta driver expires in 120 days from the time of installation. When this happens, users should install the latest Sound Blaster X-Fi driver available. Oy oy oy oy oy!!! uhuhuhuh....

    This download includes Creative Audio Console, which enables you to use the Sound Blaster X-Fi features and functions.
    Does not address all the reported general "crackling" issues, but it does resolve some specific issues with crackling. Investigations with some motherboard manufacturers are ongoing, and we hope to provide a general solution soon.
    Resolves some issues to improve your overall audio experience.

    Added Feature:
    Supports OpenAL 1.1

    Game Fixes:

    For Prey
    Resolves the issue of the computer not responding

    For Quake 4 (version 1.04)
    Resolves the issue of the computer not responding when the error message "Quake 4 has encountered an error and needs to close" is displayed
    Resolves the issue of mono speaker out in surround sound environments
    Allows you to hear audio from speakers when you select the OpenAL X-Fi option as the audio driver
    Allows audio channels to stream to correct speakers

    For Battlefield 2
    Allows the Ultra-High Audio setting in a multi-player game

    For Battlefield 2 (version 1.12)
    Allows you to hear audio from speakers when the X-Fi audio driver option is selected

    For Doom 3 (version 1.3)
    Allows you to hear audio from speakers when EAX 4.0 is enabled
    Resolves the "pop" issue during the Chainsaw attack sound effect sequence
    Removes "hiss" from the front left speaker
    Allows panning
    Plays the Ambient sound effects correctly

    For Unreal® Tournament 2004 (version 3369)
    Allows you to hear audio from speakers when running in hardware OpenAL mode (the System Driver check-box is cleared)

    For Unreal Tournament 2004 (version 3355)
    Allows reverb in native OpenAL mode
    Allows music to play correctly during gaming in Native OpenAL mode

    For Dungeon Siege® (version 1.11)
    Resolves the issue of the computer not responding during benchmarking

    Music or Movie Playback Fixes:
    Resolves the issue of the computer not responding when DTS signal is passed through Creative MediaSource™ Player/Organizer
    Removes X-Fi CMSS-3D Speakers distortion when playing DivX stereo content

    Recording Fixes:

    For ASIO
    Resolves the issue where audio stops when you turn on the inputs in Cubase® LE
    Resolves the issue of the computer not responding when the sample rate changes in Cubase
    Resolves crackling during playback and monitoring at 1 ms
    Resolves the issue where signal is lost when the sample rate changes in Cubase LE or SX3

    For Audio Creation Mode
    Removes distortion when recording to a 44.1 kHz multi-channel wave file in Audio Creation Mode with 44.1 kHz master sampling rate
    Removes the pops and crackles during record monitoring and changing sample rates

    For Microsoft® Windows® XP Professional x64 Edition
    Resolves the issue where no audio is heard from your speakers occasionally when playing 3D MIDI files
    Resolves the missing instrument issue when playing a MIDI file in all modes

    For Cubase LE 1.09
    Resumes normal playback of MIDI tracks when changing sampling rate

    Others
    Resolves the "recording process aborted" issue during a 44 kHz multi-channel recording
    Resolves the issue of the computer not responding when recording with Creative MediaSource Player/Organizer
    Resolves SoundFont® issues where notes distort and change pitch during playback and recording

    General Fixes
    Allows your computer to quit Suspend mode when enabling "Automatically Enable Headphone Settings" even when headphones are not connected to your computer
    Resolves the issue where no audio is heard when testing the X-Fi CMSS-3D Headphone in the Game Mode console
    Resolves the noise issue when your computer quits Standby mode

    Fixes for developers:
    Allows effects to be loaded in EAX4.0 mode of your test program (EAX50ShowDSound)
    Resolves the issue of the computer not responding when loading a 2D Sound in your test program (DSound50_OpenAL 1.1)
    Resolves the issue where there is no upmix when switching effects
    Resolves floating point offset issue in OpenAL
    Resolves the issue of the computer not responding while using synchronous start through native OpenAL

    Requirements:
    Microsoft Windows XP Professional x64 Edition or Windows XP Service Pack 2
    Sound Blaster X-Fi series audio device "
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.