TechSpot

New Widescreen and fuzzy Suse

By IBN
Aug 19, 2006
  1. I have recently bought a Viewsonic 19" Widescreen and my SUSE OS is all fuzzy i cant see anything. Its fine with My window OS though. I beleive it may have to do with the new resolution?

    Any take on how to get it normal again.
     
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,657   +323

    Desktop menu -> Control Center

    Check Graphics Card and Monitor, make sure your monitor is listed there, and correctly chosen.

    Then open up Screen Resolution and set that to what you want. If its still not fixed change the refresh rate, also check the box that makes it default.
     
  3. IBN

    IBN TS Maniac Topic Starter Posts: 625

    Thanx for the reply.

    The thing is, I cant see anything enough to do that. Its too fuzzy to make out anything. I can just make out the desktop but not enough to carry out your instructions.
     
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,657   +323

    that sucks. heh.
     
  5. IBN

    IBN TS Maniac Topic Starter Posts: 625

    Indeed! I have been googling to no avail.

    EDIT: If the problem is due to the resolution or refresh rate is there a way in which I could boot into failsafe mode and change them there somehow?
     
  6. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,657   +323

    Ok, here is an idea. Boot into SuSE with your old monitor, and then change the monitor to your new one. Then plug in your new one, that ought to get it close enough you could read or see where the refresh rate can be changed.

    I had a similar problem when I switched from 17" CRT to 19" Dell LCD, but it wasn't bad enough that I couldn't see what was going on.
     
  7. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,916   +9

    Depending on how the X server is configured, there might be a way to change the screen resolution on the fly by pressing CTRL + ALT + numpad plus or minus keys.
     
  8. IBN

    IBN TS Maniac Topic Starter Posts: 625

    That didnt work. Even after connecting my Analog 17" CRT the same problem occurs. So I just reinstalled SUSE and during setup I set the resolution on 1280 by 1024 @ 16bit colours.

    My 19" Widescreen resolution of 1440 by 900 doesnt work when I test it during setup. Maybe it will work when I figure out and install the nvidia drivers.
     
  9. IBN

    IBN TS Maniac Topic Starter Posts: 625

    OK an update on the situation.

    Make sure you test the resolution during the very final stage of SUSE installation. Its from that i figured out that only the 1280 by 1024 @ 16bit colours would work.

    After installing the nvidia drivers you can set the resolution @ 1440 by 900 if you got a 19" widscreen that is.
     
  10. YosefM

    YosefM TS Rookie Posts: 66

    Sounds like you solved it. Sorry I got here late.

    If you ever need to do this again, try this instead:

    Use Ctrl+Alt+F1 to go to console (F1-F6 give you virtual ttys 1-6, 1 is console & lets you see the results of your init command) - login as root.
    Once there use the init command to shut down the graphical login & x-server by modifying the runlevel to 3 (init 3).
    Use sax to reroll your x-server config or go through yast if you prefer. Be sure to use startx to test it - use Ctrl+Alt+Backspace to kill the x-server when you're done testing or get stuck in a mode that doesn't work.
    When you're done go back to runlevel 5 (init 5), logoff root, Alt+F7 to get back to the graphical desktop.

    ...Have a lot of fun.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.