TechSpot

No Device Drivers at ALL!!!!! PANIC!  PANIC!

By Lovepeaceguru
Jan 8, 2006
Topic Status:
Not open for further replies.
  1. After trying to install a new printer, discovering that my USB ports won't detect anything, My Computer and IE suddenly taking ages to start, everything hanging everywhere, I find that my Device Manager window is completely empty!!!!!!

    PnUP is activated.

    Can anyone help????

    I have to earn a living on this PC tomorrow!
  2. iss

    iss TechSpot Chancellor Posts: 2,896

    If you are using XP try using system restore to go back to before you installed the printer.
  3. Lovepeaceguru

    Lovepeaceguru TS Rookie Topic Starter

    Thx for your help but I've tried that! more..............

    I tried two system restores. They made no difference

    I've tried:

    is PunP working?
    Tried Apropos fix
    Tried correcting registry entries in ENUM permissions

    Nothing works.

    Also system was hanging on startups and shutdowns, sometimes needing the big switch to get out of it. Now you can click on IE or My Computer or Control Panel and it takes ages for them to load. Usually I find myself with about five instances of each all loading at once.

    Frequently web links wont work. The only thing I can do is avoid a left click - use right clicks to save shortcut and then paste it into address bar.

    Please can somebody help. My kingdom for a horse!

    Thx Thx Thx in advance
  4. Lovepeaceguru

    Lovepeaceguru TS Rookie Topic Starter

    Please help!!!

    Is there nobody who has experienced the same problem - a completely EMPTY Device Manager, USB ports all dead and system hanging everywhere??

    Please help!!
  5. iss

    iss TechSpot Chancellor Posts: 2,896

    Do you know if the printer works? if it was defective it is possible it damaged your machine.
  6. Lovepeaceguru

    Lovepeaceguru TS Rookie Topic Starter

    No I'm sure the printer is OK. It was delivered by Oki the day before this happened. It's an Oki C5450n which I want to run with Postscript emulation. It works fine and will print test pages, logs, etc from it's control panel.

    I should perhaps have given more informatioin about my system:


    INTEL P4 3.4GHz, socket 775
    ASUS P5GD1-VM motherboard, onboard LAN (Intel Pro 100), onboard graphics and audio disabled
    American Megatrends BIOS version 1010.005
    2 x 512MB PC3200 400MHz DDR
    200GB Maxtor serial ATA drive - C
    500GB Seagate serial ATA drive - D
    Samsung/Toshiba DVD writer - E
    Sony Q28A DVD writer - F
    Sony DRX-810UL external DVD writer on USB - G
    ATI All in Wonder X800XL graphics card
    Creative Soundblaster XFi Xtreme Music sound card
    Logitech Dinovo Media keyboard, seperate keyboard and numeric panel/remote with mouse on powered USB hub
    Logitech Communicate STX webcam

    Thank you very much for your assistance. If there is anything else you can do to help I would be very grateful.
  7. OpTiMuSpRiMe

    OpTiMuSpRiMe TS Rookie Posts: 211

    try unhooking the printer and see if you still have the same issue.. if not then make sure that all your drivers are up to date.. after that i would reinstall the printer drivers..also do you have a windows partition set aside for only windows so that if you need to reinstall you don't lose any info?and you said that none of you usb ports were working at all?? and you have an external drive hooked to the system.. try unhooking all the usb drives except mouse and keyboard then plug the printer in... you might be overloading a usb controller.. that is if your mouse and keyboard and printer are usb.. if not then just unhook all usb and try the printer if it usb.. but if it is paralell then reinstall the chipset drivers then try a bios flash for a possible hardware conflict
  8. Lovepeaceguru

    Lovepeaceguru TS Rookie Topic Starter


    The printer has been unhooked throughout this as it showul be when new drivers are being installed. They have been unistalled and reinstalled about six times. I will try again and this time make doubly suyre there is no refeence to them left on the system

    Ihave unhooked all tyhe USB devices. Only thing now is keyboard which has USB and keyboard PS2 keyboard connector.

    No I have system, Windows and program files on C: (and a little data), data on D:. Should I change this?

    I just spoke to a friend of mine, a Microsoft techie. All he could do was advise me to run the MPS reports which I'm doing.

    Thanks very, very much for your help. Any other ideas????
  9. Lovepeaceguru

    Lovepeaceguru TS Rookie Topic Starter

    SUCCESS!!!! Well partial success anyway!

    I have a partial resolution to my problem!

    Thanks to everyone who offered help.

    First option was check that PuNP was started - OK. Later I discovered that Universal PuNP must NOT be started!

    Second option was Aproposfix which I assume is to get rid of some specific spyware/adware/malware.

    Third was I tried editing some permissions in the registry but I didn't really understand what I was doing.

    Fourth was I ran sfc/scannow - whatever that is!

    Also system was hanging on startups and shutdowns, sometimes needing the big switch to get out of it. Now you can click on IE or My Computer or Control Panel and it takes ages for them to load. Usually I find myself with about five instances of each all loading at once.

    Frequently web links won't work. The only thing I can do is avoid a left click - use right clicks to save shortcut and then paste it into address bar. I have tpo switch back and forth betwen web browsers using teh Task Manager. OIften the Task Manager itself freezes with the button still "pressed down".

    I've also been using my SpeedUpMyPC utility which allows you to give CPU priority to a particular window. A combination of this, Task Manager and a hell of a lot of patience just about keeps me going

    Oh, and I updated all my chipset drivers along the way.

    MY DEVICE MANAGER WINDOW IS NOW FULLY POPULATED!!!!!

    Oh joy! The printer is working too. The solution? It was to do with permissions. I had to spend a lot more time and give a lot more thought to it. (I still don't understand it properly). It's in HKEY Local Machine "Enum"
    whatever that means?

    So many thanks to the Annoyances.org forum which first gave me the idea for that fix.

    BUT!!

    Some things are better like loading IE or My Computer or Control Panel. They're still slow though and I can still find myself with loads more browser windows open that I need. On IE though browsing still suffers froim the same problem. Links won't work. I have to copy shortcut and paste into another window.

    Java linlks often don't wprk eiuther. I uninstalled and re-installed Java. Maybe there's some slightimprovement but browsing is still a pain.

    So now it comes down to a performance problem, mainly in IE.

    Shall I uninstall and reinstall IE?

    Why has this happened. Could Malware/spyware viruses be reponsible?

    Any help gratefully received and because it's only fair, I'll make sure every forum gets a full report when it's all fixed (It will be won't it?)





    System Description

    INTEL P4 3.4GHz, socket 775
    ASUS P5GD1-VM motherboard, onboard LAN (Intel Pro 100), onboard graphics and audio disabled
    American Megatrends BIOS version 1010.005
    2 x 512MB PC3200 400MHz DDR
    200GB Maxtor serial ATA drive - C
    500GB Seagate serial ATA drive - D
    Samsung/Toshiba DVD writer - E
    Sony Q28A DVD writer - F
    Sony DRX-810UL external DVD writer on USB - G
    ATI All in Wonder X800XL graphics card
    Creative Soundblaster XFi Xtreme Music sound card
    Logitech Dinovo Media keyboard, seperate keyboard and numeric panel/remote with mouse on powered USB hub
    Logitech Communicate STX webcam

    I run Windows XP Home Service Pack, fully updated. I defragment with Perfect Disk at least once per week.

    I use the following security software:

    Norton Internet Security 2006
    Ad-Aware SE
    Spyware Doctor
    Spy Bot
    Microsoft Antispyware
    Spyware Blaster
    Spy Sweeper

    All are updated regularly and full scans performed at least every other day.

    I also use Registry Mechanic at least once per day. And this episode has added about a dozen other utilities to my amoury.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.