TechSpot

No display after psu installation

By space037
May 18, 2016
Post New Reply
  1. I got a new psu for my old desktop and when I turn on the computer there is no display on the monitor. I believe this is because not all the wires from the psu are into the computer. I know some dont get plugged in at all, but I only have 4 plugged in the big 24 pin connecter, the 4 pin connecter, and two sata cables connected to a hard drive and what seems to be the usb docking section.

    I really need help with this if pictures are needed I can upload some please help.
     
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    It would really help us if you gave the hardware you have installed plus the make and model of said hardware. Photos will help as long as they are clear and large enough so we can see with clarity.

    Why did you feel the need to get a new psu?
     
  3. space037

    space037 TS Rookie Topic Starter

    Hi I needed a new psu because the computer was not starting at all. I'll have attached photos of the connecter, psu, and motherboard
     
  4. space037

    space037 TS Rookie Topic Starter

    I'm trying to upload photos from my phone and having a very hard time. How do you do this?
     
  5. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    Did you buy this system as one unit and if so what is the make and model of your system? Please tell us the make, model, and the amount of wattage it said it delivered of your old psu as well as your new psu stats.
     
  6. space037

    space037 TS Rookie Topic Starter

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...