TechSpot

No display

By emmaspring
Oct 30, 2008
  1. have recently just installed a new Motherboard,CPU,RAM, and a Graphics Card although the system boots and i go motion from all the parts i cant seem to get the screen from the monitor to show up which normally happens straight from the boot up i have checked the cables in the back of the graphics card are correct but this is the first time of a boot process so i need to access the screen to make any BIOS changes to the motherboard etc but the screen just wont come up plz help
     
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Make and model of motherboard please.
     
  3. emmaspring

    emmaspring TS Rookie Topic Starter

    ta

    ECS K8M890M-M (V1.0A)
    Socket AM2 for AMD Athlon™ 64 processor
     
  4. CCT

    CCT TS Evangelist Posts: 2,653   +6

  5. emmaspring

    emmaspring TS Rookie Topic Starter

    tryed that hun....nowt happend..got 1 g ram...
     
  6. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Are you getting one comforting single BEEP on post?

    If not, something you bought or how you connected it is amiss.

    Sometimes.disassembly and re-assembly OUTSIDE the case helps to find a problem. Using only 1 or the other of your Ram modules can also be tried.

    There are Guides here under a heading like that about fail to boot or some such. Look there also.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...