TechSpot

No Drive letter & Volume Mix-up

By Lisa-Marya
Jan 17, 2007
  1. I run WinXP on a pc with 2 hard drives, and an external hard drive for back-ups. It was working perfectly.
    Recently I had the 10Gb C: drive replaced with an 80Gb one.
    When I formatted and re-installed XP the Drive letters were haywire - C: had become H:.
    My supplier came and unplugged the second hard drive and I re-installed XP which then showed correctly as C: He then revisited and reconnected the second hard drive but it did not show in My Computer, though he said the computer recognised a second volume.
    After he'd retreated, saying he was baffled, I just thought I'd restart again and, to my delighted surprise, the two drives both then showed up in 'My Computer'
    BUT now, in Computer Management, D: is called a USB Removable Storage Drive and the external drive has no drive letter, and is viewed as a Logical Drive. If I double-click on it the menu is greyed-out except for 'Delete Partition'. If I click that it warns that deleting the partition will lose all data which I certainly don't want to do, although I can't now access it.
    If I disconnect the external drive the D: drive disappears from My Computer..
    How can I get the computer to label the drives correctly and make all 3 accessible?

    Thanks for reading this and for any help.
     
  2. jobeard

    jobeard TS Ambassador Posts: 13,450   +324

    solve them one at a time; keep the USB in the box (ie disconnected) until
    your C:\ & D:\ are correct -- THEN address the USB issue.
     
  3. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,640   +322

    In Disk Management you can right click and manually set the drive letter. You won't be able to choose D until the current D drive is changed to something else.
     
  4. Lisa-Marya

    Lisa-Marya TS Rookie Topic Starter

    Thanks to Jobeard & SNGX for your two replies. When I disconnect the external drive, the D: drive disappears from My Computer.
    When I try to allocate a drive letter, to the external drive, the relevant menu is greyed out, except for 'Delete Partition'.
     
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,944   +167

    Disconnect your CD ROM/Burners from power.

    How are your 2 hard drives configured? CS (cable select) or Primary Master (C) and Primary Slave (D)? CD's configured CS (cable select) or secondary master (E), or secondary slave (F)? This IDE connection/configuration is critical...

    Disconnect your second hard drive, and pull the external. With all IDE devices except your C drive disconnected, boot you system. Shut down. Connect the second hard drive. Boot. Shut down. Connect the CDROM(s). Boot. Connect the external and see what you have now
     
  6. Lisa-Marya

    Lisa-Marya TS Rookie Topic Starter

    Thanks Tmagic.
    The Drives are configured Primary Master and P.Slave; Secondary Master and Sec.Slave.
    I'll have to organise outside help to disconnect the second hard drive again and to disconnect the CD ROM/Burners from power, but I'll post when I've done what you advise.
     
  7. Lisa-Marya

    Lisa-Marya TS Rookie Topic Starter

    Tmagic. A knowledgeable friend did what you advised but to no avail - the situation remains the same. When only the C: is connected the computer does not then recognise the D: when it is reconnected.

    Thanks for any further help.
     
  8. Eddy Rassy

    Eddy Rassy TS Rookie Posts: 106

    I would check the IDE cable itself for the drives and how it is connected. The blue connector should plug into the primary IDE channel on the motherboard, the black connecor should plug into the master drive and the gray connector should plug into the slave drive. Also make sure that the jumper settings on both drives are configured one for master and one for slave.
     
  9. Lisa-Marya

    Lisa-Marya TS Rookie Topic Starter

    Thanks, Eddy. Will the jumper settings be clearly marked on the drives? There are two wide grey cables. One has been replaced because of possible wear, hoping it was the cause - but it made no difference.
     
  10. Eddy Rassy

    Eddy Rassy TS Rookie Posts: 106

    Yes they are marked. Look at the printed side of the hard disk, it shows you the settings. all the cables are grey but I was talking before about the connectors colors. The cable is made up of 3 connectors, the blue fits in the motherboard IDE primary header, the black fits in the primary master drive and the grey connects to the primary slave drive
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.