TechSpot

Ntkrnlpa.exe problem

By bumblegrum
Sep 14, 2008
  1. For some time now I have been getting blue screens and have only just now been able to work out how to set up debugging. The minidump appears to point towards ntkrnlpa.exe as being the problem.

    This is an assumption on my part as I do not have the technical background to be able to fully interpret what the dump is indicating.

    I have attached a txt file of the minidump.

    I wonder if someone would mind casting their eyes over the minidump information and perhaps give me some feedback on how I may correct this issue please?

    Cheers
     

    Attached Files:

  2. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    0x8E errors are strong indicators of hardware issues. The driver cited is a core Windows driver that is too general to help much.

    My best advice at this moment is to read this link and follow the good advice. Let us know if your issues are resolved or not.

    http://www.techspot.com/vb/topic51365.html
     
  3. bumblegrum

    bumblegrum TS Rookie Topic Starter

    Many many thanks for the valued feedback. I've carried out all the procedures outlined in the link and will see what happens. My system certainly loads quite a bit quicker now so the signs are good so far.

    No problems were found with the memcheck and there was very little dust and debris in my system but that has been cleaned (I normally clean my system every 2 months anyway).

    If I have any further problems expect another post.

    Cheers
     
  4. bumblegrum

    bumblegrum TS Rookie Topic Starter

    Unfortunately none of the option there have worked. My most recent crash came while installing .NET framework 2.0. I do have to admit though that it hasn't happened again - yet - and I have had a space of maybe 6 hours to enjoy life again.

    Given that I've only recently managed to interpret the "geek speek" to enable me to instal and use the Windows debug tool, I'm not sure whether sufficient earlier minidumps have been provided in the atached files.

    If someone could have a look at them and - hopefully - point me in the direction of a solution it would be most appreciated.

    Cheers
    Brian
     
  5. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    Two of your minidumps are 0x8E errors and these are mainly caused by hardware issues. In both core Windows drivers were cited which is not much help because they are too general.

    However, in one the uTorrent.exe was noted.

    Third minidump error is 0x07E: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED

    A system thread generated an exception which the error handler did not catch. There are numerous individual causes for this problem, including hardware incompatibility, a faulty device driver or system service, or some software issues. Check Event Viewer (EventVwr.msc) for additional information.

    In this one TfFsMon.sys was cited and this is is related to ThreatFire Filesystem Monitor by PC Tools.

    It is possible that this driver and the UTorrent.exe may not be playing nice together.

    Try the following -

    1. Run chkdsk.

    2. Run a full haddrive diagnostics, especially the Long test, with the free utility provided by your harddrive manufacturer.
     
  6. bumblegrum

    bumblegrum TS Rookie Topic Starter

    I ended up formatting my hard drive and starting again but that hasn't solved the problem. Everything is fine until I start to do something. I can instal programs no problem - just can't use some of them because they crash my system but have worked perfectly in the past.

    I have had a look at the crash dumps but they make little sense to me but all appear to say pretty much the same thing.

    uTorrent and Threatfire have not been reinstalled.

    It would be appreciated if someone could cast their eyes over the attached crash dumps in the hope of pinpointing something that may enable me to solve this issue. I have attached the last 5 of 8 in total.

    Could there be a setting problem somewhere?

    If this is any help my system is:
    Motherboard: ASUS A8N-VM CSM
    Processor: AMD 64 ATHLON X2
    RAM: 2 x 1GB DDR (1GB per channel)
    Hard Drives : 2 x SATA (1 x 500GB and 1 x 260GB)
    VIDEO: NVIDIA GeForce 6600 GT Ultra2 256MB DDR
    OS: Windows XP Pro SP3

    Cheers
    Brian
     
  7. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    Three 0x8E errors which are caused by hardware. In fact, two state hardware as the problem but nothing definitive. The third one cited ntkrpamp.exe which is a core Windows driver and thus too general to provide any help.

    One 0xA and these are usually caused by hardware. Core Windows driver was cited.

    Last one is 0x7F and the most common cause is hardware. Core Windows driver was cited.

    * How long did you run Memtest, i.e. # of passes?

    * Did you run a full haddrive diagnostics like I suggested before, especially the Long test, with the free utility provided by your harddrive manufacturer? If you have a harddrive either with bad sectors or is failing a reformat isn't going to help.

    * Everything is pointing to a hardware issue, but what it is we can't tell at this moment.
     
  8. bumblegrum

    bumblegrum TS Rookie Topic Starter

    Sorry for the delayed reply. Here's the results of the tests:

    Both hard drives passed OK
    Memory ... yeah well .... The basic test after 11 runs was OK however I did an extended test after that and found some problems with the Stride38 test.

    Pass 1 produced 2 errors at 3bf9045c and 7afd045c both of which were expecting 00000000 but found ff000000

    Pass 2 produced 4 errors at 3bfd045c, 7b79045c, 7bf90454c and 7afd045c all of which were expecting 00000000 but found ff000000

    I stopped the test after the 2nd pass figuring that the same errors would appear in future passes.

    Is this the potential problem and I need to replace the RAM?

    Cheers
    Brian
     
  9. nickc

    nickc TechSpot Paladin Posts: 923   +11

    it means u need to replace u're memory or at least the stick u were testing when u got the error, there is no repair.
     
  10. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    What nickC said; if you've got errors you need to replace. i commend you on your diligence.
     
  11. bumblegrum

    bumblegrum TS Rookie Topic Starter

    Thanks for the most valuable help guys. I've installed a new matched pair of RAM and run the extended test without any problems. Now I'm going to try a few of the programs that I was using when the system crashed to see what happens.
     
  12. bumblegrum

    bumblegrum TS Rookie Topic Starter

    For some reason the Board won't allow me to respond to PMs - it says I have to be over 15 even though my DOB is in my profile that shows I'm 62.

    Stride tests (6 and 38) are part of the advanced test sets in WINDIAG available from http://oca.microsoft.com/en/windiag.asp

    Hope this helps.

    Cheers
     
  13. bumblegrum

    bumblegrum TS Rookie Topic Starter

    Guys, can I put forward a scenario here?

    As above 2 x 1gb RAM matched pair (1 in each of channel 1 and 2) return the errors above when tested using the Microsoft WINDIAG program.

    Testing each stick separately in channel 1 there are no errors returned - after 5 passes of the advanced test pattern.

    I am starting to think that perhaps I may have a motherboard problem?

    Over to you more knowledgeable guys for an opinion.

    Cheers
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...