TechSpot

nVidia Chipset not Showing

By Deadcell
Jul 29, 2007
Topic Status:
Not open for further replies.
  1. Hey guys i was trying to figure out if my nVidia GeForce FX 5200 was compatible with DX 9.0c because i was having trouble installing and running a game (Call of Duty2, I keep getting the "DirectX has encountered an unrecoverable error" message) and, when i looked at my hardware list under chipsets, it only shows something called Intel(R) 82915G/GV/910GL Express Chipset Family but no nVidia Graphics Chipset. What is up? Should, and how, can i re-install my graphics chipset (It came with my computer in 2005, when i still had DX8) When i tried to install a new driver from nVidia.com, it wouln't let me and someone said to disable the Express Chipset Family in the hardware manager under Control Panel<System<Device Manager. Should i? Just need someone to tell me what I really should do. THanks
  2. KingCody

    KingCody TechSpot Guru Posts: 1,568   +7

    the nVida FX (5000) series cards were DirectX 9.0. support for DirectX 9.0c began with the nVidia 6000 series cards

    but regardless of that, it sounds like you may be using the onboard video. go into device manager and expand "display adapters". you should see NVIDIA FX 5200 there.

    if you don't then you're still using the onboard video. you should then go into your BIOS and disable the onboard video (or choose PCI/AGP as the first video device), then once your FX5200 becomes the active video card you should be able to install the latest drivers for it

    good luck :wave:
  3. Deadcell

    Deadcell Newcomer, in training Topic Starter Posts: 36

    A Question For King Cody, If I May

    "if you don't then you're still using the onboard video. you should then go into your BIOS and disable the onboard video (or choose PCI/AGP as the first video device), then once your FX5200 becomes the active video card you should be able to install the latest drivers for it" - King Cody

    I undertand the problem you explained about the DirectX compatibility problem, but i already loked into the Device manager under Display Adapter and alreay knew that the Graphics Card was not Displayed there. You are not the first to suggest this plan of action described in this quote to me, but i don't know how to do it. Can you reply with a little "Talk to Me Like I'm 10" tutorial and tha'ld be great..Thanks 4 ur help dude
  4. KingCody

    KingCody TechSpot Guru Posts: 1,568   +7

    I don't know why you felt the need to start a new thread for this, in the future you should always reply in the existing thread instead of creating a new thread on the same exact topic. hopefully a moderator will read this and merge this thread with topic 83091...

    now to answer your question...

    1. first you need to enter your BIOS. you enter the BIOS by pressing the [usually "DEL" but may be "F1", "F2", F12, etc] key as the computer boots up.

    2. once you're in the BIOS, you need to browse through the pages until you find an option to [select primary video device or an option to disable the onboard video]. each BIOS menu and options are unique to the motherboard it's installed onto, since I don't have your motherboard in front of me, I can't give you exact step-by-step instructions but it should be easy enough to find by yourself.

    3. once you have set the PCI/AGP as primary or disabled, press [usually F10] to save and exit the BIOS (or goto the last BIOS page and select "SAVE SETTINGS AND EXIT").

    4. let the computer reboot, then go into device manager and verify that your FX5200 is shown under "DISPLAY ADAPTERS". if you see it there then you're allset to install your drivers and configure your display settings

    good luck :wave:
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.