Nvidia forceware problem

By abhinit90
Apr 18, 2007
  1. i recently downloaded the newly released nvidia forceware 158.19 for xp but when i run it , it gives me an error saying that

    ""Nvidia could not find any drivers compatible with your hardware , setup will now exit .""

    i have windows xp sp2,nvidia 6600gt and 1gb ram.i was previously using 93.71 forceware.

    i am damn sure the drivers are for xp as in the setup it clearly states

    "Disply drivers for windows xp ".

    if not possible plz provide me with the links for the forceware version.

    plz help
  2. sghiznaneck

    sghiznaneck TS Maniac Posts: 403

    That series of drivers isn't for XP. They are solely for Vista. You need to completely uninstall those drivers, download the most recent (97.94) and install those drivers.
  3. abhinit90

    abhinit90 TS Rookie Topic Starter Posts: 115

    as far as i know even on the site 158.18 is for vista whereas 158.19 is for xp plz help me

    hey anybody tell me the problem or coreect me if i am wrong in my ^^^ statements
  4. sghiznaneck

    sghiznaneck TS Maniac Posts: 403

    You need to roll back the driver to the previous version. You are right, as this version is for XP/Media Center. I checked the NVIDIA site for your Series 6000 card, and the most current driver version it calls for IS 93.71. The 158.19 is for support of the Series 7000 and Series 8000 cards. This is probably why the setup program can't install the drivers because version 158.19 doesn't support your card.
  5. abhinit90

    abhinit90 TS Rookie Topic Starter Posts: 115

    i lokked and saw that it was the beta version so can i excpect the support of my card in the final release.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...