OS wont reconize WD SATA 250G

By OrionV
Jul 2, 2008
  1. Hi,
    Not sure I’m in the right thread but here we go.

    OK I have a Biostar T-Force 550 mother board with a western digital 250GB Special Edition Serial ATA drive (model WD2500JD).

    I have been trying to load ANY Windows OS on it, and every time I go to install windows on to the HD windows cannot find the Hard drive and I get a please load device Drivers. I have downloaded the utility/driver software from western digital and that didn’t work it also doesn’t see the HD.
    I have put in the original CD that my T-Force cam with and still it cannot find the HD or drivers to install the OS on.

    I do have the bios already set to raid so that it recognizes my HD.
    And while in the bios I can detect the HD

    I am at a total loss.
    This system did work earlier but I contracted a virus got paranoid and wiped out the system.
    Now it won’t let me load windows
    Help any ideas
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    Go to Western Digital's website and download their installation software and run it on your system. The drive needs to be setup for the first time
  3. raybay

    raybay TS Evangelist Posts: 7,241   +9

    If you had it working before, the WD should not require the WD hard drive set up, but it is worth a try if all else has failed.
    Is the hard drive detected in the BIOS when you cold boot and press the <DEL> key?
    Check for cable errors by removing and seating all cables. Change to different cables off the power supply set, as well.
    It is possible the hard drive is bad, from shipping, or any lateral impact.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...