TechSpot

Pages not loading right

By ButterDuck
Apr 16, 2016
Post New Reply
  1. Some websites only load in text-form,http://I.imgur.com/QJkVovA.png, for example.
    And some don't load and just say my connection has been reset, such as gmail, and I've tried multiple things but they haven't seemed to work
     
  2. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,554   +2,897

    This resembles a bad connection with an ISP. If that is the trouble you are having I wish you better luck than we have in getting it fixed.

    I've seen these symptoms many times, dealing with our crap ISP. Nobody seems to be authorized to replace a box that lets water in every time it rains. And they are never given supplies to try and at least seal the leak either. So every time it rains we are likely to experience disconnects and very bad connection rates. They don't seem to care how many times their IT people are called out to the same address either.
     
  3. ButterDuck

    ButterDuck TS Rookie Topic Starter

    So, I am RIP?
     
  4. ButterDuck

    ButterDuck TS Rookie Topic Starter

    I cant edit my posts apparently.
    So, on my phone, websites work. And on my brothers PC, they also work. Its only on mine.
     
  5. ButterDuck

    ButterDuck TS Rookie Topic Starter

    K so problem solved.
    I just had to restart PC. GG.
     
    cliffordcooley likes this.
  6. jobeard

    jobeard TS Ambassador Posts: 9,322   +622

    It's amazing how frequently a reboot will correct bizarre symptoms :)
     
    Leeky, learninmypc and cliffordcooley like this.
  7. bluejolls

    bluejolls TS Booster Posts: 107   +8

    Search Google on how to adjust your Router MTU settings (maximum transmission units) to see if that makes any difference.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...