TechSpot

PCTV vs External HD - "Deayed Write Failed" :-|

By eobrah
Sep 19, 2007
  1. Hello

    My problem is that I bought this Pinnacle PCTV Hybrid Pro Stick 320E and it works perfectly. But it needs to suppress most of my usb equipment and it's VERY unpleasant!

    I have an external hard drive (USB2) connected and it has always worked without any trouble at all. But now I get these errors whenever I plug in the PCTV.

    After a short period it says "Delayed Write Failed" and then it won't work with either Azureus or Emule (Both P2P Clients). The drive is still visual in explorer but after I reboot the system it doesn't seem to locate the HD in the explorer.

    The external hard drive and the PCTV is the only hardware that connects using the USB2 standard.

    The USB 2.0 controller seems to work properly.

    I've got a strong feeling that the Pinnacle driver and firmware is the issue 'cause all of the other hardware worked without any trouble at all untill now.

    I'm very confused that I can't make these two devices work together.

    Can anyone please help me?
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Please update your User Profile to include your system specs as detailed as you can, and tell us where you are located
     
  3. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    I'm going to guess its the drive on the way out or
    I just had this happen the usb cable replace that see if you still have errors
    all else fails remove from drive case and hook up internally

    back up all data before you mess with yer stuff
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...