TechSpot

Performance problem - low FPS

By Bellroth
Jan 26, 2006
  1. Hi

    I have read almost all the threads inhere about low performance and bad FPS but i cant find anything that looks like my own problem. And sorry if i ask stupid questions but im no expert...

    I recently bought a new computer cuz my old wasnt good enough anymore, cant remember the specs but it was sumthing like

    XP1600+
    768 ram pc2700
    FX5200

    The new computer specs are

    Intel(R) Celeron(R) CPU 3.06GHz
    NVIDIA GeForce 6600 GT
    768 ram still pc2700 (gettin 1 gb 3200 tomorrow)

    The problem is that my new computer runs almost the same as my old computer; in WoW (like 30 fps outside cities, 10 inside) and in JK2 i got unstable fps 20-60 and cant get it higher no matter what.

    I ran a benchmark 2003 on high performance in graphic and scored bout 5500. After that i used the default setting for my graphic but changed to high quality and got a score on 6913. Doesnt make sense to me. My results:

    Game test did 126.7 - 56.4 - 47.0 - 43.8
    CPU test did 36.0 and 7.1
    Feature test did
    Single-text: 1481.7 MTexels/s
    Multi-text: 3778.8 Mtexels/s
    Vertex shader: 20.3 fps
    pixel shader 2.0: 115.2 fps
    Ragtroll 28.3 fps

    Sry if i write too much or if my english might be bad. But it seems like the CPU is running pretty bad...

    //Bellroth
     
  2. iNoob

    iNoob TS Rookie Posts: 68

    My guess would be because of your RAM. PC2700 is pretty slow for modern standards. Also, the celeron is naturally slower than P4 and Athlon (P4 3Ghz and Athlon 3000+) chips, so that could drag your fps down.

    Do you have large applications running in the back when you play? the HUGE range of fps for Jk2 seems to me like the processing power is being taken away and returned repeatedly.

    *edit* just did some googling and some guy was getting the 3DMark03 marks as you (~6900). He updated his driver to 70.41 and got a new score of ~8200. So try updating your driver.
     
  3. Athena

    Athena TS Rookie Posts: 66

    I would think the new RAM will help you out a bit. At least wise making games run "smoother" but w/ a celeron CPU games will always be a bit tough on that CPU. :blackeye:
     
  4. Bellroth

    Bellroth TS Rookie Topic Starter

    Hm i knew the Celeron was slower than the P4 and Athlon, but a friend of mine did the 3dmark test with a p4 3.02 Ghz and same system and got same score in CPU, maybe a bit higher but nothing to talk about. But after i got the new RAM's i got 7381, and after i clocked the 6600GT i got 8346. My FPS is gettin better and games are running better, but my JK2 is still quite jumpy.

    And no, i got nothing running in the back that uses any of my CPU. My avarage CPU usage in windows is about 3%.

    And i have the newest Nvidia driwers, 81.98...

    But i have one last question that kinda irritates me not to know. WHen i look under details of my system in 3dmark, it says my RAM speed is 2.0 Mhz? Thats pretty slow. When i had the old in, it had speed 1000.000000 sumthing on block 1, and 2.0 mhz on block 2..
     
  5. master_spartin

    master_spartin TS Rookie

    I had 5200fx video card with 1gp 667mgz ram 1.8 core2duo
    jk2 run 80-90fps. upgraded video card to xfx 8600gt xxx
    now runs 20fps.:confused:
     
  6. Acclamator

    Acclamator TS Rookie Posts: 261

    Please create a new thread for your problems.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...