Please Help Very Important!!!!

By Dman7467
Jan 21, 2004
  1. I was going through my PC and i was cleaning all the dust and so forth off like i do every month and i put the side panel back on and tried turning it on and everything runs but the monitor wont get the signal so it just leaves me with the blinky green light instead of coming on.........what may b the problem?

    thnx for your time reading this
  2. perpetlu

    perpetlu TS Rookie Posts: 21

    A harshly suggestion (i think) do u using onboard vga? if u dont, get ur manual for ur mobo and read the manual throughtly about jumper, it may be off accidently

  3. cokecan72

    cokecan72 TS Rookie Posts: 35

    i had somethin like this with my friends comp, everything turned on, fans, HDD, cd-rom etc but the monitor was continuesly in powersave mode (blinkin green light). we tried everything, even wondered if it was the processor??? we took the heat sink off but the clip snapped, then we had the idea of clearing the cmos. we did it then tried to hold the heatsink down ontop of the processor while we switched it on (bad move lol) we think it worked, cos we got something on the screen but then the processor fried. you could try this, well only the cmos part lol :D
  4. vassil3427

    vassil3427 TS Rookie Posts: 640

    How exactly did you "dust" it?

    Make sure everything is still plugged in, especially the cpu fan. Perhaps static built up and killed it?
  5. SubKamran

    SubKamran TS Rookie Posts: 166

    I'm wondering to. You should have an air duster (those compressed air cans) to dust the computer because static can build up and frie the motherboard.

    I need to buy a air can, but for now I just blow it all off :D
  6. perpetlu

    perpetlu TS Rookie Posts: 21

    Did you use vaccuum?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...