Poodle effect: Mozilla to disable SSL version 3.0 in Firefox 34

  1. Mozilla has announced that SSL version 3.0 will be disabled by default in Firefox 34, which is due for release on November 25. The announcement comes in the wake of a vulnerability that was discovered in said version of the security...

    Read more

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...