Power Supply Suspect Compaq EVO D510 Pentium 4

By giladreams
Apr 23, 2008
  1. Power Supply Suspect Compaq EVO D510 Pentium 4.
    Hi, I am having a problem with my daughters EVO D510 SFF Pentium 4.

    There is a green light on on the mobo, and for a while when we would push the on button the fans would try to turn, and then stop; then a blinking red light would blink, but nothing else would happen.
    Now, nothing happens. The green light on the mobo is still on.

    Any advice will be greatly appreciated,

    I am new to the forum and am thankful that you are here,
  2. Matthew

    Matthew TechSpot Staff Posts: 5,260   +92

    Very well could be the PSU, or, the CPU, RAM and the motherboard itself.

    Borrowing or buying a PSU to swap with your current unit is probably the safest place to start, currently.

    Exactly what model do you have? Can you find a picture of the case online? I ask because it appears that all models apart from one use an OEM PSU, and not an ATX PSU.
  3. giladreams

    giladreams TS Rookie Topic Starter

    It's EVO D510 SFF Pentium 4, 2.7GHz

    I haven't posted here enough yet to be able to put an image or link in here, but if you put what you need to in front of this, you'll get there:

    Thanks for your response, and I appreciate your help!

  4. Matthew

    Matthew TechSpot Staff Posts: 5,260   +92

    Aye, that's the "Small Form Factor" model, which, has an OEM PSU from what I can tell. You can buy that on eBay here. However, considering the price, it might be worthwhile to take a look at the search results for "EVO D510 SFF" and see if you can get the chassis along with the PSU and other parts for a comparable price.
  5. giladreams

    giladreams TS Rookie Topic Starter

    I'll try it soon and get back with how things went.

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...