POWER works, FANS work, PC DEAD?????

By liameastop
Jan 28, 2006
  1. Hey Everyone,

    OK well here is my problem. Recently my dad moved his PC from his house to his office (onsite). This is about a 200 meters walk outside. It happend to be in the middel of an electrical storm, wasn't raining but lots of lighting. Since then, i have set his computer up again and it doesn't work at all. I have opened the case to have a look and noticed that all the fans are working, the motherboard LEDS work, as does DVD drive, but not the Burner, the graphics card fan works (which is powered through the mother board). The USB inputs are producing no power and the graphic card isn't producing any connection to the monitor. What seems to happen is the copmuter turns on but nothing works. Is it fried? What do you think has happended and why?

    Thanks, any interest would be appreciated. I have also taken both hard drives out and installed into second PC to check is they are working. Both the hard drives are not recognized.

    I am lost of what to do?

    Regard Liam
  2. DonNagual

    DonNagual TechSpot Ambassador Posts: 2,404

    You get NOTHING but moving fans? No beeps or anything, no input to monitor?

    First thing I'd do is re-seat your ram modules. Just take them out and plug them in again. They may have come a little loose on the move. Happened to me once and scared the :hotouch: out of me.

    If that doesn't do it, take out your vid card (if you have one) and re-seat it. Do it to all your add-in cards.

    Let us know if this works, and welcome to Techspot!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...