TechSpot

Problems with SuSe Linux, OpenLDAP, and Samaba

By golfing22
Mar 22, 2006
Topic Status:
Not open for further replies.
  1. Well right now I am trying to build a primary domain controller in linux, here is my set up:

    SuSe 10
    Samba
    OpenLDAP

    I've used Yast to update everything to the latest version.

    When I issue the command to populate the LDAP database it gives me these errors:
    Use of uninitialized value in substitution (s///) at /usr/local/sbin//smbldap_tools.pm line 120, <CONFIGFILE> line 16.
    Populating LDAP directory for domain foobar.tld (S-1-5-21-2139989288-483860436-2398042574)
    (using builtin directory structure)

    adding new entry: dc=example,dc=tld
    failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 469, <GEN1> line 2.
    adding new entry: ou=Users,dc=example,dc=tld
    failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 469, <GEN1> line 3.
    adding new entry: ou=Groups,dc=example,dc=tld
    failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 469, <GEN1> line 4.
    adding new entry: ou=Computers,dc=example,dc=tld
    failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 469, <GEN1> line 6.
    adding new entry: uid=Administrator,ou=Users,dc=example,dc=tld
    failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 469, <GEN1> line 7.
    adding new entry: uid=nobody,ou=Users,dc=example,dc=tld
    failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 469, <GEN1> line 8.
    adding new entry: cn=Domain Admins,ou=Groups,dc=example,dc=tld
    failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 469, <GEN1> line 9.
    adding new entry: cn=Domain Users,ou=Groups,dc=example,dc=tld
    failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 469, <GEN1> line 10.
    adding new entry: cn=Domain Guests,ou=Groups,dc=example,dc=tld
    failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 469, <GEN1> line 11.
    adding new entry: cn=Domain Computers,ou=Groups,dc=example,dc=tld
    failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 469, <GEN1> line 12.
    adding new entry: cn=Administrators,ou=Groups,dc=example,dc=tld
    failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 469, <GEN1> line 16.
    adding new entry: cn=Account Operators,ou=Groups,dc=example,dc=tld
    failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 469, <GEN1> line 18.
    adding new entry: cn=Print Operators,ou=Groups,dc=example,dc=tld
    failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 469, <GEN1> line 19.
    adding new entry: cn=Backup Operators,ou=Groups,dc=example,dc=tld
    failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 469, <GEN1> line 20.
    adding new entry: cn=Replicators,ou=Groups,dc=example,dc=tld
    failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 469, <GEN1> line 21.
    adding new entry: sambaDomainName=foobar.tld,dc=example,dc=tld
    failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 469, <GEN1> line 21.

    Please provide a password for the domain Administrator:
    Use of uninitialized value in substitution (s///) at /usr/local/sbin//smbldap_tools.pm line 120, <CONFIGFILE> line 16.
    No such object at /usr/local/sbin//smbldap_tools.pm line 322.

    Does anybody know what the problem is and what can I do to fix it,

    Thanks,
    golfing22
  2. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Good luck, I had really good time setting this up :)

    You have to set up LDAP first, then go over the config files in /etc/smbldap-tools before you can do any smbldap* stuff.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.