TechSpot

Problems with USB portable devices - computer freezes

By jonese26
Jun 14, 2006
  1. Hi, I'm having a problem whereby my computer freezes as soon i insert either my ipod, or other portable media device (512MB flash drive/mp3 player). As soon as it goes in, the computer freezes and i have to restart, its very strange and annoying. Anyone else had this problem?
     
  2. Vigilante

    Vigilante TechSpot Paladin Posts: 2,120

    I would first check the physical port. Make sure there aren't any bent pins and no shorts.
    If the physical is fine, I would perhaps check for updates to your motherboard drivers, and possibly the USB drivers specifically, if available.

    I suppose it freezes when using ANY port? You should have at least 2, try them all.

    It's a start, good luck
     
  3. shippy2

    shippy2 TS Rookie

    portable usb devices freeze computer

    Hey, my pc just started doing the same thing! Been through everything, disabled usb legacy mode in bios, uninstalled all usb root hubs unplugged all usb devices and rebooted, and changed drivers in usb host controllers. Nothing solves the problem. I'm at a loss. My PSP and mp3 player used to work but now the pc just freezes when I plug them in..... :suspiciou :suspiciou
     
  4. Vigilante

    Vigilante TechSpot Paladin Posts: 2,120

    Are you using an administrator user account?

    Try plugging in a USB device that has never been plugged in before, to make sure it isn't a software problem.

    You might go into Start -> Run -> services.msc and make sure any plug n play or USB related services are running.
     
  5. shippy2

    shippy2 TS Rookie

    Universal Plug and Play Device Host: stopped

    Vigilante,

    I tried a device never used before and it also froze the pc. However, in the services section I noticed that Universal Plug and Play Device Host is not started...Do you think I should start this service and try plugging into the USB port again?
     
  6. Tedster

    Tedster Techspot old timer..... Posts: 10,074   +13

    yes - enable plug and play.
     
  7. shippy2

    shippy2 TS Rookie

    Thank You Tedster And Vigilante!!

    Big thanks to Tedster and Vigilante!I have no idea how the Universal Plug and Play Device Host service got stopped but you fixed the problem. I spent hours over the last two weeks trying to figure out the issue. Thanks again and Kudos to you guys! :grinthumb
     
  8. Vigilante

    Vigilante TechSpot Paladin Posts: 2,120

    Excellent news.

    Be sure, in services.msc, to set Upnp startup type to automatic. And not manual or disabled. And if it gets screwed up again by itself, there could be other issues as well.

    Enjoy
     
  9. ltchang

    ltchang TS Rookie

    USB Problem on my IBM T41 Laptop

    My laptop is IBM T41, O/S is XP. When plug mouse into USB port, it shows "unknown device". When plug in memory sticks, computer freeze. The memory sticks work on other laptop and desktop.
    This is what I have done (but still not solve the problem):
    1) delete all USB drivers (automatic reinstalled after restart)
    2) remove battery overnite
    3) restart BIO
    4) clean out dust
    What shall I do.
    ltchang
    3/27/08
    Good News. I have resolve the problem.
    1) Insert a USB Cardbus into the Wireless Adapter slot
    2) After computer accept the card
    3) Insert a USB Flash Memory stick into the Cardbus
    4) Once the computer accepts the stick
    5) The regular USB slot will work
    Try it.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.