TechSpot

PSU problems

By Tomagone
Dec 15, 2012
Post New Reply
  1. I've managed to get my hand in a Jeantech 1000 watt modular PSU. The only problem is it didn't come with any cables, except data power cable, although the mobo and CPU power cables are built in. All the connectors appear to be 6pin so I was thing of getting some of those connectors that turn two 4 Molex connectors into a 6pin PCI-E and just using it in reverse for powering fans e.c.t. Would this work, will it damage anything?
    On another note, I put the PSU into the case and connected it to the mobo (there's no CPU yet) and I can't get the system to turn on. I tested if the PSU was duff by shorting a ground pin and the green cable on the mobo power cable and it worked. So its either a duff mobo or wired it in wrong. It's also worth noting that the PSU isn't connected to anything but the mobo, I don't know if that changes anything.
    Any help would be really useful so thanks in advance.
     
  2. LukeDJ

    LukeDJ TS Addict Posts: 414   +112

    Not entirely sure, but I don't think the PC will boot without a CPU?
     
  3. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,479   +624

    ^-- My opinion also.
     
  4. Blkfx1

    Blkfx1 TS Addict Posts: 894   +173

    A computer will not boot unless there is RAM & CPU installed to the board. Without those core components your machine will not turn on.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.