TechSpot

Putting Back My Documents in Files Stored on This Computer

By lj50
Jan 12, 2006
Topic Status:
Not open for further replies.
  1. I opened My Computer and I noticed My Documents was missing from the Files Stored on This Computer section. Is there a way to get it back in there? I tried System Restore, unchecking and checking Files Stored on This Computer in Power Toys, and sfc /scannow. Any help will be appreciated. Thanks.
  2. dparod

    dparod Newcomer, in training

    Hi lj50,

    I just discovered this happened to one of the users on my computer as well. I'm running Windows XP Pro. Here's what I figured out to fix it:

    *Start Registry Editor (Start > run > regedit.exe)
    *Go to this key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\DocFolderPaths
    *In the right window you should see a list of all the users who should have a folder listed under "Files Stored on This Computer" when you open up My Computer. (There may be a default string listed too)
    *Right click in the right window and create a new string value.
    *For the name, type the name of the user whose folder is missing, then hit enter. Ex: If you log on as lj50, type lj50 as the name.
    *Right click on the string you just created and click Modify.
    *For value data, type the address of where the missing user's My Documents folder is. Generally it is at C:\Documents and Settings\XXXXX\My Documents, where XXXXX is the user's name. So if the user name is lj50, type C:\Documents and Settings\lj50\My Documents.
    *Click OK and close out of the Registry Editor. You may need to restart your computer for the change to take effect.

    Keep in mind that changing the Registry is dangerous. You should probably create a restore point and/or back up the registry before you make any changes.

    I hope this helps and good luck!
  3. lj50

    lj50 Newcomer, in training Topic Starter

    It worked like a charm. Thank you very much.
  4. alvian

    alvian Newcomer, in training

    I found another solution which does not involve editing the registry. I hope it will work for you too.

    Open "Windows Explorer", right-click "My Documents", choose "Properties". In the "Target" box try changing the target folder location (click "Apply" & choose "Yes" to create directory & move contents). Try the "Restore Default" button too.

    When the "My Documents" target is changed, Windows seem to recreate the missing/corrupt registry entry.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.