Radeon 9800 Pro keeps crashing my system

By sefiant
Nov 21, 2004
Topic Status:
Not open for further replies.
  1. Hello, I really need help with this problem about my day-old radeon 9800 pro.

    The main thing about the problem is that whenever it runs a 3d supported application/games like "Emperor: Battle for Dune" and "Halo" my computer crashes immediately after the game has loaded or rather the instance the main menu appears. Another problem that irritated me was that each time i clicked on the ati driver settings icon in the system tray, the screen flickers lines briefly before the driver settings dialog box loads.

    I tried uninstalling the previous on-board Intel Extreme Graphics driver on my Gigabyte GA-8IG1000 Pro-G Mobo and installed the ati drivers that came with the graphics card I bought on cd as well as trying the catalyst drivers but to no avail.

    Oh, another thing, I even ran a few benchmarks (MadOnion, Vulpine, etc.) and it also came up with the same problem. Upon loading of the tests, the system crashes and some unable to even load. However, in one of the tests, the video froze but the sound was still active.

    So if anyone could please provide a workable solution and free me from this craziness and frustration it would be very much appreciated.
  2. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +17

    Hello and welcome to Techspot.

    Go into your bios and disable the onboard graphics see if that helps.

    Regards Howard :wave: :wave:
  3. sefiant

    sefiant Newcomer, in training Topic Starter

    yep that's been done already

    when I installed the new video card it automatically removed the shared memory for the onboard graphics and i don't see it anymore in the bios; when i boot up, i get the full 512 mb of memory (instead of 480 mb before), so i assumed the onboard graphics is disabled
  4. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +17

    click on start run and type dxdiag.

    Run all the display tests.
  5. sefiant

    sefiant Newcomer, in training Topic Starter

    yeh ive tested both the display and sound tests and they were all successful
  6. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +17

    In your bios make sure that your graphics adaptor is set to agp and that the agp aperture is set to 128
  7. sefiant

    sefiant Newcomer, in training Topic Starter

    But I cannot even access the graphics adaptor in bios because it isn't there let alone change agp aperture. Can driver cleaner be a possible solution?
  8. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +17

    In bios go to advanced and select resource configuration look for primary graphics adaptor and select it then set it to agp if it`s not already.

    Then go into chipset configuration select agp aperture and set it to 128.

    Then go into Peripheral configuration and make sure any onboard graphics are disabled.

    Save your changes and exit.

    Your system should reboot with the new settings.

    Regards Howard :grinthumb
  9. sefiant

    sefiant Newcomer, in training Topic Starter

    i dont need to disable onboard gfx because my mobo detects the radeon and automatically disables the onboard gfx . ive set aperture to 128 and the primary gfx adaptor (init display first in my bios) has always been agp . i even disabled the audio and it still keeps crashing on every 3d app even the benchmarks and ati catalyst control center 3d settings =..(
  10. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +17

    Have you considered taking the card back and getting another one just to rule out the possibility of a faulty card?

    Regards Howard :grinthumb
  11. sefiant

    sefiant Newcomer, in training Topic Starter

    yeh on saturday, but im also bringing my whole tower along with current hardware components just to see if they can do anything, man it gets me angry ...

    specs:
    Gigabyte GA-8IG1000 Pro-G Mobo
    Intel Pentium 2.4Ghz Celeron
    512Mb DDR Ram
    ATI Radeon 9800 Pro
    Windows XP SP2
    LiteON DVD-ROM
  12. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +17

    Yeah that`s PCs for you.

    If you manage to sort it out please will you let us know what the problem was and how it was fixed.

    Thanks and good luck.

    Regards Howard :grinthumb
  13. Pelsdyr

    Pelsdyr Newcomer, in training Posts: 35

    I had the same Problems

    I yust delited ServicePack2 and now it works wonderfull.

    Tryed that?
     
  14. Greeno

    Greeno Newcomer, in training Posts: 394

    Just out of interest, why did you suggest an aperture of 128? I'm not being picky or anything, just curious...
  15. comper

    comper Newcomer, in training

    Saphire?

    Just wondering if your card is a Saphire... I have a Saphire Radeon 9800 Pro that has been stalling out my system from a month or two after I bought it. It won't let me game at all now... Disappointing for how much money this beast cost. Let me know! Thanx
  16. sefiant

    sefiant Newcomer, in training Topic Starter

    No its a powercolor and thanks guys for your suggestions, however all it was is that it was a faulty card or rather as they explained as DOA (dead on arrival). They gave me another one it finally thanks to god works fine. "Emperor: battle for dune" works great but "cs: condition zero" was lagging like 1 fps. Just Reinstall???

    Also another thing after installing halo demo it runs pretty slow and has NO TEXTURE whatsoever. At the start it warns me that i might need to update my gfx drivers. Update to new ATI drivers???
  17. ---agissi---

    ---agissi--- TechSpot Paladin Posts: 2,382   +15

    Greeno: 128 because the card has 128MBs of ram ;)
  18. comper

    comper Newcomer, in training

    Drivers

    People are having many problems with the new catalyist drivers, so you might want to find the previous set. I have personally had mucho problementos with the new drivers. Let me know how things go... my ati 9800 Pro 256 is still out of commission... so bad that I have actually resorted to a nVidia MX 4000 128... feel my pain! So tell me how things go (Hope that new card works better for ya)
  19. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +17

  20. bedlam_4

    bedlam_4 Newcomer, in training Posts: 182

    Hi, Howard

    I downloaded the Omega drivers you mentioned. I have a Radeon 9800 pro 128. It aint broke but it could be better. HL 2 locks and stutters a bit. Especially when EAX is enabled on My Audigy card. I'm thinking of fiddleing with the clock and memory speeds some. What is your take on these Omega drivers?
  21. sefiant

    sefiant Newcomer, in training Topic Starter

    i dont know about omega drivers but im going to install the latest ati driver (the one without catalyst control center) but im wondering if i should uninstall my current ati driver first (in combo with using driver cleaner) or can i just install the latest driver without uninstalling the current one???
  22. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +17

    I would deffinitely reccomend uninstalling the current driver first.

    Regards Howard :grinthumb
  23. bedlam_4

    bedlam_4 Newcomer, in training Posts: 182

    I tried to install the smaller ati catalyst (26.mb) driver first but it was corrupted. I then installed the bigger driver (29.8mb w/control panel) and it crashed my machine and or failed to initialize all applications. I went back and redownloaded the smaller driver and the second time for it worked o.k..
    As to uninstalling your old drivers. You are not supposed to have to. The uninstall is part of the setup program for the new catalyst drivers. If you want to do it any way I would down load ATI's uninstall all ATIDRIVERS TOOL. This tool is found here. http://www.ati.com/support/drivers/misc/catalystutils.html.

    Any one use the omega drivers yet?
  24. sefiant

    sefiant Newcomer, in training Topic Starter

    thanks again i just installed the latest catalyst driver without uninstalling the current one and halo works fine but it just gets slow (about 16fps) when im looking at vast areas/environments (such as beach, forest, etc.) but it might just be my cpu or memory (2.4ghz celeron, 512 ddr ram)
  25. ---agissi---

    ---agissi--- TechSpot Paladin Posts: 2,382   +15

    Play with the settings!! Lower the resolution and texture quality, they'll have the biggest effect!

    Btw, celerons are AWEFUL!

    your celeron runs about as fast as a 1.5GHz P4, just so you know.

    Friends dont let friends buy Celerons!

    but you've already bought one :( :evil:
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.