TechSpot

Radeon x1300 Display Problem,  Help!

By Meshuggah27
Jan 9, 2007
  1. My desktop and everything displays and loads fine. When loading programs it works fine. But when i go into games it displays things but it displays them in boxes.

    For example, I tried to play Company of heroes, And all the trees, and the soldiers, and everything else pretty much was boxes.

    Then i tried Rome Total War (Older game) and the same problem. The only way i could tell the difference between the horse and a soldier was the horse was a block with little blocks under it.

    THEN, I tried Titan Quest. I couldnt even get into the game because all of the menu buttons were blocks and i couldnt make out anything.

    I removed ALL the ATI drivers, Re-installed them, Removed them again and installed the Omega drivers and still the same problem. I havent tried reformatting yet and i hope i dont have to, But if i do then thats not a problem.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.