Radeon X1650 Pro - It Can't Be This Hard

By LeMat
May 25, 2007
Topic Status:
Not open for further replies.
  1. O Techy Semi-Demigods of TechSpot, repute of your expertise travels far and wide! Heed yon internet traveller and help him with this ridiculous installation process, I beseech ye!

    So here goes. I've got the 512 MB X1650 Pro -- the AGP version (because I'm cool like that). Physical installation went without a hitch; the problem is with this Catalyst software.

    I pick out the Express option for driver installation as recommended, and all goes smoothly. The control center installs, no problem. Then come the explosions.

    The first failure comes about right after initial install. I get a nice round of "Try to set up your display adapter with a standard VGA driver before running setup."

    The ATI website recommends that I perform a manual install through Control Panel. No sweat.

    I run it through, and the Unknown Drivers are now identified as the Radeon X1650 Pro. Problem solved, right?

    Not so much. It requests that I restart my computer for the changes to take effect. I do so, start 'er back up, and we've got a MOM.Implementation error.

    I check out the website, it recommends that I install .NET 2.0 Framework and Catalyst 7.1 instead of the new version. I do. And the whole process starts over again. VGA error, MOM.Imp error.

    It really can't be this hard, can it? Is anyone familiar with this problem? You guys would be my heroes forever; I've got a LAN party coming up and I'm running at 800x600. :p

    Thanks for reading! (... help!) :)
  2. BloodRaven

    BloodRaven Newcomer, in training Posts: 118

    this same exact thing is happening to my computer with my radeon 9800 pro the only thing that i changed was i DID update my .NET framework thats when this message started happening. the only thing im seeing people say about how to fix this is to update .NET framework. what is that is what caused it....and yes ive tried re- installing .NET
  3. zipperman

    zipperman Newcomer, in training Posts: 1,423   +7

    Same for me

    Net framework has to be installed and the installation instructions
    followed exactly.I did my 9600 recently ok.
    But not online.I saved it to my desktop and closed my Browser.
    Do you have DX 9c ? Theres an update that doesn't change it's description.
    Kind of a patch.
    Do this update a Microsoft.com.
  4. zipperman

    zipperman Newcomer, in training Posts: 1,423   +7

    This is my results

    I think Windows update made it net framework 2.0
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.