TechSpot

Razer mouse sensitivity out of wack on Linux

By Jskid
Sep 28, 2012
Post New Reply
  1. I got a left handed Razer Deathadder mouse :) I installed the drivers on Windows and it works great. Sadly there aren't any drivers for Linux and the mouse sensitivity is all messed up. In the settings I have 0 acceleration but it still moves to fast at the slightest movement. Any solutions?
     
  2. Siavash

    Siavash TS Member Posts: 48   +12

  3. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 4,377   +127

    Yep Linux is awful in this regard.
    Is the problem that the sensitivity is too high or that you have unwanted mouse acceleration?
     
  4. Jskid

    Jskid TS Enthusiast Topic Starter Posts: 433

    Thanks it worked:) But I can't figure out how to get it to automatically do this at start up. I created the file but don't know how to make it load when I log in (the directions are too unclear to me).
     
  5. Siavash

    Siavash TS Member Posts: 48   +12

    Can you please make clear which Linux distribution and desktop environment are you using?

    I assume you are using something Ubuntu based. First you need to open 50-mouse-deceleration.conf in a text editor as super user :
    Code:
    sudo nano /usr/share/X11/xorg.conf.d/50-mouse-deceleration.conf

    Then put these inside that file :
    Code:
    Section "InputClass"
      Identifier      "Razer DeathAdder"
      MatchProduct    "Razer DeathAdder"
      Option          "ConstantDeceleration" "5"
    EndSection

    Then press CTRL+X , answer yes to save the changes and reboot.

    Resource : ArchLinux Wiki
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.