TechSpot

RDP to my xp machine.

By drappendix
Aug 13, 2006
  1. im trying to RDP to my xp machine. The settings in my router are forwarded correctly,changed the listening port in my registry and opened the port in te windows firewall. but i still cant connect on port 3390. but if i change all the settings back to run on port 3389 i can connect. the same problem occurs on my other machine running server 03 ?!?!?! is there another setting that i have to change? the wierd thing is that server doesnt let that port go through either under RDP, so i know its not because its xp.if anyone knows the setting that isnt letting this through i would be very thankful.

    Edit: please use proper thread titles from now on. Thanks.
     
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Did you actually restart the RDP service or the computer after changing the port number in the registry?
     
  3. drappendix

    drappendix TS Rookie Topic Starter

    I restarted the computer. Howwould i go about restarting the RDP service ..is it right in the services section from cpanel?
     
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Don't worry.. If you restarted the computer, then surely the service got a restart too.

    After changing the port number (and restarting), check with netstat or some other network monitor (TCPView from www.sysinternals.com) whether the RDP service actually started listening on the new port.
     
  5. drappendix

    drappendix TS Rookie Topic Starter

    yes it was started. but the thing is i am unable to rdp to the xp machine even behind the router when the port is set on 3390. this is very odd, even the guys at my job (an isp) could not figure this out.
     
  6. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Can you connect directly over the LAN using the LAN IP?

    Whan you connect, what kind of error message do you receive? Try connecting to that port with telnet. Do you get an immediate "connection refused" or a timeout?
     
  7. Rick

    Rick TechSpot Staff Posts: 4,573   +65

    How are you changing your ports? Registry hack? I'd double check it to make sure the registry edit is accurate.

    When you change your server's RDP port and change your client's RDP port, try something like this to verify the settings you changed are actually are in effect:

    MSTSC /v:#.#.#.#:3389 (#.#.#.# should be your IP address)

    The idea I have here is to change your settings to use port 3390, but manually specify 3389 for your client instead. If it connects, then we know your listening RDP port was never changed (for whatever reason). If it doesn't connect, we didn't really prove anything, but oh well. :)
     
  8. drappendix

    drappendix TS Rookie Topic Starter

    that is exacltyl ho w i change the port...through the registry. http://support.microsoft.com/kb/187623/ . i havent had a chance to check any of the telnet connection stuff. but really i am looking foer any other settings that affect rdp, instead, everyone is trying to check if the port is open. thanks for the help when i get back ill check on that other stuff. but if anyone knowsof others settings that is what im looking for. such as registry clashing or other in consistencies.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...