"Run As" dialog box popping up all of a sudden?

By UnWarierMage224
Aug 24, 2006
Topic Status:
Not open for further replies.
  1. Hi all,

    On my old laptop, whenever I go to run a program... or anything, for that matter... I get this dialog box that says "Run As". It gives me two options:

    Run as current user with a checkbox to toggle "prevent unauthorized program activity"

    OR

    Run as another user, with a place to type in login names and passwords.

    The computer (It's five years old) just started doing this all of a sudden. How do I get rid of it?
  2. Peddant

    Peddant Newcomer, in training Posts: 1,644

    You can disable the Run as service AKA "Secondary logon service" -

    Right-click My Computer/Manage/Computer Management,expand the Services and Applications/Services.

    In the details pane, right-click the Secondary Logon service, and then click Properties.

    In the Properties dialog box, set Startup type to disabled, and then click Stop.

    After the computer stops the service, click OK to close the Properties dialog box,
    and then close Computer Management.
  3. UnWarierMage224

    UnWarierMage224 Newcomer, in training Topic Starter Posts: 84

    Hi Peddant,

    Thanks for the tip, it worked!
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.