Satellite L350-210 touchpad not recognized

By josbd
Oct 2, 2010
Post New Reply
  1. Hi guys, been a while. I hope you can help!

    I have a Satellite L350-210, it is about a year old and running Vista HP.

    Out of the blue, the touchpad stopped responding. I have tried enabling/disabling it using the FN + F9 key, updated the drivers, nothing. So then I uninstalled the drivers altogether, and reinstalled them using the ones listed on the official synaptics site, and the one on the toshiba site, nothing. Uninstalled again, and let the laptop find the drivers. Nada.

    I went to the device list and the Synaptics device isn't even listed under mouse and pointers where it usually is. The only evidence it even exists is it still seems that it is listed as a startup program and when going to the mouse menu in the control panel, there is a seperate tab with the synaptics logo on it, although nothing in the tab is clickable. Everything is grayed out no mention of touchpad at all.

    Does anyone have a clue? I would be most grateful for any help!
  2. mike1959

    mike1959 TechSpot Addict Posts: 1,039   +15

    You could try, in device manager, right-click on 'Mice and other pointing devices', choose 'uninstall'. Then re-boot. Windows should discover the touchpad again. I was asked to look at an Acer Aspire which had the same problem. I think I would lift up the keyboard, see if it's possible to find the plug from the touchpad to the motherboard. Unplug it. Re-boot windows. Shut down. Plug it back in, re-boot Laptop and if all is well it should force windows to find it again and install the drivers.
  3. CAMusing

    CAMusing TechSpot Enthusiast Posts: 328

    1) Make sure the touch pad is enabled (still not working? Go to step 2)
    2) Turn off the computer
    3) Unplug the power cord from outlet or laptop
    4) Remove the battery
    5) Press and hold the power ON button for 30 seconds
    6) Re-insert battery
    7) Plug in power cord
    8) Turn on the computer
  4. josbd

    josbd TechSpot Enthusiast Topic Starter Posts: 289

    Mike: I did uninstall the drivers via device manager. When rebooted, laptop went searching for drivers, found them and announced it had installed them. But it was still non operational.

    CAMusing: I have heard of this trick before, but didn't think it would work, so didn't consider it! Shall give that a whirl today.

    I shall let you know.

    Thanks both for taking the time to give this some thought.
  5. josbd

    josbd TechSpot Enthusiast Topic Starter Posts: 289

    Tried the option of taking out batt, holding down power button etc, but I am afraid that did not work either.
  6. CAMusing

    CAMusing TechSpot Enthusiast Posts: 328

  7. josbd

    josbd TechSpot Enthusiast Topic Starter Posts: 289

    Thanks very much for your advice, and for your time. Much appreciated :)
  8. CAMusing

    CAMusing TechSpot Enthusiast Posts: 328

    Anytime josbd! :)


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.