Screwed up device drivers

By Paul881
Jul 13, 2007
Topic Status:
Not open for further replies.
  1. This afternoon, in a rush of blood to the head, I updated my Logitech QuickCam software. What a mistake! Not only did it not work, I couldn't uninstall it and had to revert to going back to yesterdays Restore point.

    All well and good, except that now, all my Sound, Video and Game controler drivers have the dreaded yellow exclamation mark against them. In spite of re-installing my sound card driver five times this afternoon, the yellow peril still remains and so I have no sound.

    I can see that I am going to have to step into the registry - a scary thought. Does anyone have any other bright ideas or suggestions? Would a proprietary Registry cleaner help?
  2. jobeard

    jobeard TS Ambassador Posts: 13,275   +280

    USUALLY, we delete the existing driver via the Device Mgr and then reboot to
    let the system autoconfigure the device.
  3. villan881

    villan881 Newcomer, in training

    The computer auto senses new hardware, (my soundcard) I load the drivers - but still get the error code 39 message.

    So, with the Logitech camera and drivers removed, (using Add/remove programs)I am still plagued by none of my Sound, Video and game controllers working - I am still getting the dreaded "drivers cannot be located - code 39" error messages. This applies to my midi keyboard, delta 66 sound card, POD XT etc.

    I have used CC to try to see if there are any ploblems in my Registry - nothing relevent was found.

    I have tried deleting and re-installing my Delta sound card umteen times to no avail. Something is masking or interfering with the registry that is not letting the drivers load correctly. Any further suggestions?
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.