TechSpot

Sony Laptop

By TypeX45
Feb 7, 2006
  1. I have a sony laptop s430, I replaced the hard drive in an older sony and every thing worked fine. After installing a hard drive in this one the screen does not come on. I don't hear any post beeps and am afraind I fried the mobo. My question is does sony place switches to prevent people rom opening up there lap tops if not how do I test the mother board.
     
  2. Eric Legge

    Eric Legge TS Rookie Posts: 132

    Which version of Windows is on the laptop?

    What size and type of hard drive is it - IDE or SATA?

    It's very unlikely that you fried the motherboard by changing the hard drive, it's more likely that the drive wasn't installed properly.

    Does the battery have to be installed to use it from the mains, or can if work without the battery?

    Have you tried to connect it to an external monitor?

    Have you tried to replace the original drive?
     
  3. TypeX45

    TypeX45 TS Rookie Topic Starter Posts: 144

    Sorry about that but Windows XP is the operating system, 60 gig hard drive IDE, I have tried with the battery and without. Also I have tried to an external monitor. I can here the hard drive turn on and the hd light come on but nothing.
     
  4. Eric Legge

    Eric Legge TS Rookie Posts: 132

    The new drive could be faulty.

    You didn't say if you tried replacing the original drive.
     
  5. TypeX45

    TypeX45 TS Rookie Topic Starter Posts: 144

    The original drive was dead in the first place. I tested the snot out of it. I also check out the new one and it worked fine on another computer. Thats why I think I fried the motherboard.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...