TechSpot

Sound Card Troubles

By Robgamer
May 7, 2007
  1. I own a creative x-fi xtremegamer sound card. I have windows vista home premium, and I just got the computer today. On the toolbar where it has the sound picture, it says No Audio Output Device is installed. What do I do?
     
  2. tipstir

    tipstir TS Ambassador Posts: 2,393   +107

    Go and download audio drivers for your sound card or have the computer maker tech support send you what you need. If you put the card into the system you're self you need to found out if you can get Vista drivers for it?
     
  3. gavilan

    gavilan TS Rookie Posts: 62

    You need to go to Creative's website and download the latest Vista drivers. Unfortunately, their Vista drivers for that card are still pretty immature, so a lot of features do not yet work in Vista. But the XP drivers will not work under Vista.
     
  4. sghiznaneck

    sghiznaneck TS Maniac Posts: 403

    True statement. Problem with hardware such as X-Fi and the 8800 GTX is that the drivers just aren't there yet. Microsoft has promised that with Service Pack 1, all these bugs will be ironed out. I upgraded in December just for DS10, and then in January purchased the full version of Vista Home Premium only to have the disk sitting in a drawer collecting dust awaiting SP1. I refuse to install Vista until these problems are ironed out. XP is working fine, and must admit is a very stable product. So much for staying ahead of the tech power curve.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...