TechSpot

SoundCard not working.

By mgear
Feb 24, 2008
Topic Status:
Not open for further replies.
  1. On my laptop (IBM Thinkpad t21) last night while messing I went to play a video and what do you know I had no sound.
    I thought I muted my synth on the card but it was saying the mixer or something wasn't installed but I have used the sound card before.
    Is the BIOS on it going out of wack or is it a virus that AVG didn't catch.

    Also can you install new cards on laptops like video and processors.
    The reason I ask is because my video card is 8 mb and the processors is 667 megahertz.
    The vid card is PCI.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,757   +157

    Your video and sound are on-board PCI devices, not cards like desktop computers have at times. There's no room for PCI cards in most notebooks including yours. Your processor might be upgradeable, but it may not give you much, and it may be expensive. Go to IBM's support site and see if you can find a download for your audio driver, reinstall the sound driver... and save for a much better laptop
  3. lamo

    lamo Newcomer, in training Posts: 570

    mgear, try to increase volume with hardware buttons.
  4. Tedster

    Tedster Techspot old timer..... Posts: 10,074   +13

    either your driver is corrupted, your volume or sound is turned down/off, or you physically have a broken speaker(s)

    there are no sound cards on laptops expect in some rare cases.
  5. mgear

    mgear Newcomer, in training Topic Starter Posts: 30

    I have tried that.
  6. mgear

    mgear Newcomer, in training Topic Starter Posts: 30

    The speakers worked fine before it was saying the thing.
  7. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,757   +157

    So go to IBM support... download the sound driver for your model laptop
  8. lamo

    lamo Newcomer, in training Posts: 570

    well, mgear, i can only say that these are problems with sound codec, or digital amplifier, or sound chip(of course, it's actual if you have right drivers installed for your audio chip). check if you have sound out of line-out jack.
  9. mgear

    mgear Newcomer, in training Topic Starter Posts: 30

    They do not have an update.
    Look at Audio
  10. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,757   +157

    Thanks mgear.
    that what I wanted...
  11. mgear

    mgear Newcomer, in training Topic Starter Posts: 30

    Yay, I found why it was messing up.
    I went searching through system files and found the direct driver for the card and clicked the EXE of it,the complete card was un-powered.
    Well it is fixed... For now :)
     
  12. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,757   +157

    good work mgear,
    I wish more members would look at this thread
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.