Star Wars: Jedi Knight II Jedi Outcast installation issues

By sw123
Mar 11, 2006
Topic Status:
Not open for further replies.
  1. Hi:


    I know I have posted many threads, but i need help here:

    I tried to install Star Wars: Jedi Knight II Jedi Outcast on my computer and it seems to install fine, but when it reaches the 38% mark, it stops for a second or two, then it says that there was a data transfer error and that the installation couldnt be completed. I cleaned the disk( the cd for jedi outcast), but that really all i could do. I played the game before on my PC many times, worked fine, but now all of a sudden it doesnt work. How can I get it to install correctly? If so, please reply
  2. mailpup

    mailpup TS Special Forces Posts: 8,385   +205

    If you have a second optical drive, have you tried to install from that one?
  3. sw123

    sw123 Newcomer, in training Topic Starter Posts: 752

    I have a 16x speed DVD optical drive, I will try installing from there. I will reply with results later.
  4. sw123

    sw123 Newcomer, in training Topic Starter Posts: 752

    I tried the DVD drive. Same error message, data transfer error, all that. I think it has to do with the cd, so i will replace it or try something else. Thank you for helping out though.
  5. sw123

    sw123 Newcomer, in training Topic Starter Posts: 752

    I found several copies of the disk, and 1 made it past 38% but still didnt install correctly. I took another copy and tried it, it seemed to install fine, but then it brought me to some startup box, and gave me this message:

    JK2: v1.02a win-x86 Mar 4 2002
    Initialising zone memory .....
    ----- FS_Startup -----
    Current search path:
    C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets1.pk3 (8011 files)
    C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData/base

    ----------------------
    8011 files in pk3 files

    Running in restricted demo mode.

    ----- FS_Startup -----
    Current search path:
    C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData/demo

    ----------------------
    8011 files in pk3 files
    Couldn't load default.cfg



    does this mean anything? Thank you for replying, i will try other copies now
  6. sw123

    sw123 Newcomer, in training Topic Starter Posts: 752

    I only had a few copies, but i will ask lucasarts to replace the disk, so i can play my game, maybe ill check the readme...
  7. sw123

    sw123 Newcomer, in training Topic Starter Posts: 752

    looked under readme, nothing on my problem. lucasarts better replace the disc, because they screwed up(they usually dont). I noticed something peculiar though:


    When I put the cd in, it brought me to the installation prompt. Then i tried installing it, then waited until 38% mark, and cd drives seemed to slow down and stop, then error message. is this a problem of the game? or could it be my cd/dvd drive drivers? Please let me know when you think you came up with a solution, and please dont let it involve system registry or system files, i get very clumsy when looking at these kinds of things, and also i have never been in the registry.

    Thank you for helping me out
    sw123
  8. mailpup

    mailpup TS Special Forces Posts: 8,385   +205

    Under Device Manager find IDE ATA/ATAPI Controllers. Check the IDE channels your optical drives are connected to. Right click on them and choose Properties. Click on the Advanced Settings tab and make sure the transfer mode is set to DMA and not the slower PIO.

    Check this site (Click here) for more information about DMA and PIO. If this turns out to be the problem, the article at this link tells how to fix it.
  9. TUALMASOK

    TUALMASOK Newcomer, in training

    Finally someone else has had this problem! I thought I was going insane - after about 3-4 installs from the CD's, they produced random read errors on install. Even disk copies wouldn't work. In the end the only conclusion I could reach was that this was a CD error, but I worked around it by copying all the files from the CD's onto my HDD. I have a DVD burner that can read CD's at ultra speed, and that copied all but one of the large .PK3 files, so I used my old Diamond Data CDRW 40x16x10 and copied it through Nero (I opened nero, started a new session, and used the explorer window to find the .PK3 on the JKO CD and then copied it to the HDD - for some reason this works quite well).

    A week ago I had the same problem with my Jedi Academy CD's - both games are in the Activision Essential Collection format. Maybe Activision is stooging on quality CD's?

    Damn stooges.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.