Suddenly, no power to my speakers?? Help, please....

By torrenter
Sep 12, 2007
Topic Status:
Not open for further replies.
  1. I hope someone can help here. I was getting sound from my speakers earlier today and now I'm not. But for reasons, it doesn't make sense at all.

    Firstly all volume controls seem to be fine. Volume control on the taskbar is in order. So is the volume control off my keyboard. I haven't changed any wires around recently, and the volume wheel for my Creative 2.1 I-Trigue speaker system has got power to it.

    On the wheel, when I turn it to the right and go past the "click" sound, I usually get a sound like "dud" from the subwoofer and a "bip" from the satellite speakers. Meaning power usually. But whatever I play, in iTunes, from a CD, an .avi video or whatever else, there's no sound:(

    Has anyone got an idea what could be wrong here?
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,451   +135

    Check all the speaker connections to the computer and from the speakers and subwoofer
  3. Jase123

    Jase123 Banned Posts: 1,122

  4. torrenter

    torrenter Newcomer, in training Topic Starter Posts: 203

    I restarted my PC and the sound came back:D Thanks anyway guys.
  5. Jase123

    Jase123 Banned Posts: 1,122

    Glad to hear torrenter.

    Regards Jase
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.