TechSpot

Thumbdrive / removable storage folder won't automatically open when plugged in

By Lonereaction
Nov 18, 2007
  1. I've tried everything including formatting, and when I plug the same thumdrive into my laptop, the thumdrive folder pops up, so I think it has nothing to do with the thumbdrive. It happens with my portable hard disk too.

    I've scanned my computer with Kaspersky, and no virus were detected. What must I do to get my computer to open my thumbdrive folder automatically again?
     
  2. Haydnc

    Haydnc TS Rookie

    Try this.
    Insert the USB thumbdrive into the PC. Go into My Computer and select the drive. Right mouse click and select Properties. Select the "Autoplay" tab. At the top, there's a series of file types. Select a content type and in the lower half of the screen, select the action - e.g. "Open folder to view files using Windows Explorer." Make sure the "Take No Action" is not selected. Click Apply and then repeat this for each content type. When finished, click "OK". Hopefully, this'll cure it.
     
  3. Lonereaction

    Lonereaction TS Rookie Topic Starter Posts: 16

    It doesn't work.
    I've tried that before, and I just tried it again to be sure. @_@
     
  4. Haydnc

    Haydnc TS Rookie

    Do you have any data on the drive? If you can save it to a HDD, do so.
    You say you've tried reformatting it but have you changed the method? If the drive is already formatted using FAT, try reformatting it using NTFS. If this works, either leave it as NFTS or reformat it back to FAT if necessary. I've found this will usually do the trick.
     
  5. Lonereaction

    Lonereaction TS Rookie Topic Starter Posts: 16

    Hmm. There is only the option of formatting it as FAT or FAT32.
    I tried both, and it still doesn't work.
     
  6. Haydnc

    Haydnc TS Rookie

    What OS are you using? Do you have access to either a WinXP, Win2000 or 2003 server disc?
     
  7. Lonereaction

    Lonereaction TS Rookie Topic Starter Posts: 16

    I'm using windows XP pro, SP2, updated and all.. And yes I got the CD =)
     
  8. Haydnc

    Haydnc TS Rookie

    By default, XP limits your options to FAT or FAT32 only.
    To get around this, plug the thumbdrive into the PC. Go to My Computer and right click on the drive. Select Properties. When the window opens, select the Hardware tab. You should see all the drives connected to your PC. Select the thumbdrive then click on Properties button in the lower part of the window. When the new window opens, select Policies. Click the radio button for "Optimize for Performance" then click "OK". You might actually find the window opens for you at this point.
    Go back to My Computer then right mouse click and select Format. You'll now see NTFS as an option. Save any data and then go ahead and reformat the drive. WinXP isn't too kind on NTFS formatted thumbdrives and as their lives are limited, based on the number of insertions, and to maximise this, you need to remove the drive by using the "Safely Remove Hardware" option - look in the taskbar for the green icon - when you unplug your UFD to stop any file system corruption. Simply pulling it out may corrupt the data - as I know from experience.
    If this works, I'd then reformat the drive back to FAT and go back through this rigmarole and reset the Drive Properties to "Optimize for Quick Removal" as you've less chance of corrupting the data if you inadvertently (or someone else does it for you) remove the drive without using the "Safely Remove Hardware" option if formatted using FAT.
     
  9. Lonereaction

    Lonereaction TS Rookie Topic Starter Posts: 16

    Hmm. It still doesn't help. It's fine on my laptop though, so I think the problem lies with my desktop. Thanks for the tip anyway, learnt new things.

    It's just a minor irritation, but nothing else is wrong with it..
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...