Time/Clock changes when rebooting from WinXp/Linux Dual-boot

By wheninrome
Aug 26, 2005
Topic Status:
Not open for further replies.
  1. I installed Mandrake Linux 10.1 on a spare partition on my WinXP machine a few weeks ago. When I do a complete system reboot (Going through BIOS, POST and choosing Windows XP through LILO), the time on WinXP changes to GMT. When I correct the time on WinXP, the time changes under Linux. I have tried toggling the NTP server synching option as well as other options to no avail. I have set both operating systems to local time. Can someone help me out with this annoying, yet trivial problem?
  2. Mictlantecuhtli

    Mictlantecuhtli TechSpot Evangelist Posts: 4,916   +9

    Check if /etc/sysconfig/clock has an option UTC=0.
  3. wheninrome

    wheninrome Newcomer, in training Topic Starter Posts: 20

    this is what it says in "clock"

    UTC=true
    ARC=false
    ZONE=US/Pacific




    So is this a problem with WindowsXP or with GNU/Linux? The time has been synching up fine in Linux. It seems like the problem is with Windows, but I'm not sure.
  4. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    There is no problem. It is just Windows and Unix have different philosophies when it comes to hardware clock.

    Windows thinks that it is a good idea to keep the computer hardware clock in sync with the system (software) clock. In Unix the common setting is to keep the hardware clock at UTC and shift the system clock according to the timezone and daylight savings.

    Setting UTC to false in your Linux clock config should fix it..
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.