Turned pc off ,won't reboot, help

By lgbent
Dec 2, 2007
  1. I was on my computer everything was fine,Iturned it off to work on my nephew's pc,my monitor is a Sceptre X20 Gamer and has two video hook ups so I left mine hooked up and hooked his to the other video input,everything worked fine.When I finished I un hooked his and later when I turned mine back on there was no video.The lights,fans on the mb work and the dvd door will open and close,but it won't bootup.I've switched out the memory,the video card and the hard drive to another pc and they all worked.There is one short beep when I start it.I even got a StarTech diagnostics card and the code is FF,the instructions said that means that it's past post and ready to boot. I'm about ready to send everything back fo replacements.
    Can anybody help, lgbent
  2. kiyhkuj

    kiyhkuj TS Rookie Posts: 85

    check if all the cables are plugged in properly from the monitor and also from the case. You can also visit the website and get support from them:
    Hope this helps bye.
  3. plasma dragon00

    plasma dragon00 TS Rookie Posts: 172

    well the 1 beep means everything is in working order. you say the monitor had 2 video hookups coming off of it? if you kept your pc attached but moved your nephews pc near yours to hook it up, maybe the wore attached to your pc got pulled and a pin got bent. try the other video hookup on the monitor if your pc supports it.
  4. robin_bga

    robin_bga TS Rookie Posts: 171

    I think u should first put back everything and connect back yo bro┬┤s monitor, that might explain something, otherwise if even yo bros doesnt work, then that mean u could have forcefully unplugged the vga and got it broken, or loose (ifs its not on board).
    U can also test using the onboard card to make sure that yo mobo is fine.
    Cheers mate
  5. lgbent

    lgbent TS Rookie Topic Starter

    Thanks for the replies.I've tried the vga port and the dvi port on the monitor both worked with another pc.I've tried different video cables on my pc and even connected it to different monitors but still no video.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...