Unable to access Belkin 54g wireless router with host computer

By diamonddave
Dec 7, 2005
Topic Status:
Not open for further replies.
  1. I have recently setup a small, home, wireless network. It has been running flawlessly for about two months now. A couple of days ago, we had power to the house drop out for a couple of seconds (while the host computer was on and connected to the internet) and since then I've had this problem.

    Host is running XP pro. MB has built-in network adapter which is connected to my Belkin wireless router. The router is connected to a motorola cable modem.

    My son's computer is running XP home. It has a belkin desktop wireless card installed. His computer can, wirelessly, access the internet. Everything on his system works properly and was unaffected by the power flash.

    The host computer operates normally on all local operations, but cannot access the internet. It cannot renew the IP address when I click "repair" connection. I can't directly access the router by typing in 192.168.2.1 on IE's address bar (from belkin's manual). XP tells me the network adapter is "working properly". I've looked at all of the obvious (to me) settings in the various network settings tabs and everthing matches up with how it was setup before. I've uninstalled the network adapter though XP and let XP detect new hardware at startup and that didn't help. The router and modem seem OK since they're both working for my son's system. I have tried replacing the cable from the computer to the router too.

    I have run the ping command to the router (ping 192.168.2.1) and it will occasionally pick up a packet, but will usually fail 100%. I've run it several times and a few times it has picked up 1 of 4 and once it picked up 2 of 4.

    Something seems to have failed/scrambled when the power flashed and XP had an abnormal shutdown. But I can't find it. Any help would be greatly appreciated. If more info is needed about my setup please let me know.

    Thanks in advance,
    dd
  2. toffeapple

    toffeapple Newcomer, in training Posts: 216

    go to command line and type ipconfig /release

    and then ipconfig /renew

    if this doesnt work try assigning static IP address set the default gate way to the IP of the router
  3. toffeapple

    toffeapple Newcomer, in training Posts: 216

    ...also run ipconfig from your sons computer to find the settings that are working for him
  4. diamonddave

    diamonddave Newcomer, in training Topic Starter

    Thanks toffeapple. I tried your suggestions with no luck. I did check my son's settings (using ipconfig) and manually set mine up with these. My computer now, at least, sees the network connection as "connected" (before it would always have "limited or no connectivity") but I still can't use the internet or directly access the router through the computer.
    Is there anything I can check in the registry or other direct commands I can use to check it out? It seems to be my built-in network adapter (the hardware) or some XP setting (or registry problem).

    Thanks,
    dd
  5. toffeapple

    toffeapple Newcomer, in training Posts: 216

    It won't be a registery problem..double check your IP settings..trying pinging router and the your sons PC...after that i suggest yoou remove all security and keeping adding back on see if you find a problem.

    disable the XP "firewall" for starters and if you have nortons disable that as well
  6. jobeard

    jobeard TS Ambassador Posts: 13,288   +281

    I've seen the uninstall/reinstall just retain config info and not do the job,
    and other times it works wonderfully.

    You say the router is at 192.168.2.1, so a manual config has to give
    access OR your NIC is fried!

    try this:
    view network connections
    click Local Area Connections
    click Properties​
    at the bottom you'll see TCP/IP; click it then click the Properties button.

    Now you can set a manual config
    IP address 192.168.2.101 << arbitrary, but unique>>
    mask 255.255.255.0
    gateway 192.168.2.1
    DNS 192.168.2.1

    apply/save changes and PING 192.168.2.1 should report 0% packet loss
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.