USB devices slow but work

By Charlie75
Jan 24, 2005
  1. Ok I'm not 100% sure as to what causes this and 0% as to the solution. The problem is I have a USB modem and it has been really slow ever since the computer came back from the store to install windows xp. It also disconnects and reconnects in 3 or 4 minute intervals, in java applications. Also, copying files to and from my USB pen to my computer is incredibly slow. It takes like 3 minutes to copy 15 short .txt files. I've tried on other computers and there is no problem what so ever and it takes 3 seconds to copy the same files. I am guessing it could be my usb ports since both devices use them? Am I wrong? How would I solve this? I have searched for my motherboard's drivers but I know nothing about this and am a little confused as to the exact drivers I should be getting. Using one of those programs to get computer info I got the following on my motherboard:
    Board: ASUSTeK Computer INC. P4S8X-X REV 1.xx
    Bus Clock: 133 megahertz
    BIOS: Award Software, Inc. ASUS P4S8X-X ACPI BIOS Revision 1002
    Which drivers exactly should I try to update? On the ASUS download website for my motherboard (I tried posting the url but the forum doesn't seem to let me) I see they have a P4S8X-X BIOS V1004 download. Should I get that since mine says it's 1002?
    Thank you! :wave:
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...