TechSpot

USB ports stopped working

  1. I have a problem with my desktop PC. The USB ports are not working so I can't use my keyboard or mouse.

    I'm not sure if it has any connection with this, but today I tried installing a SSD to my system with no luck. While doing that, I set the BIOS to AHCI as I read that would be the most optimal. Well, I kept getting errors trying to install Win7 to the SSD so I decided to save it for a later time. Then I turned off my PC, unplugged the SSD and plugged my HDD back in. On boot up, I entered BIOS and set settings to default. After this my USB ports stopped working..

    I have tried turning off my system, unplugging the powercord and the CMOS battery for at least 15 minutes with no luck. I have also tried plugging my keyboard into every single USB port my PC has. I can't even enter BIOS or press F8 to enter safe mode now. Any suggestions? I'm using WinXP and my motherboard is a Gigabyte GA-870A-UD3.
     
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,682   +393

    Borrow or purchase a ps2 kb. Enter BIOS and enable USB KB/Mouse. I'm not sure it is called exactly that, but it is something similar that you will be able to find. I too have a Gigabyte motherboard (older than yours even) and have had problems with it liking USB kb inputs until I explicitly set that in the BIOS. What is weird is sometimes USB will work if that isn't set, or sometimes it will half-*** work, as in I could get into the BIOS or force the boot selection menu, but then the kb wouldn't work.

    So bottom line is, I know what you are describing, but I don't know of a good fix, outside of just acquiring a ps2 kb which will get you out of this situation 100% of the time.
     
    FrederikNeertof likes this.
  3. FrederikNeertof

    FrederikNeertof TS Rookie Topic Starter Posts: 37

    Thanks a lot for your reply. I think I might have a ps/2 keyboard laying around, so I will definitely give that a try today and post back the result.
     
  4. FrederikNeertof

    FrederikNeertof TS Rookie Topic Starter Posts: 37

    So I tried connecting a ps/2 keyboard, managed to enter BIOS and turned USB controllers on - now my USB ports are working again. Problem solved.

    Thanks again, SNGX1275.
     
    SNGX1275 likes this.
  5. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,682   +393

    Awesome. Glad to hear my post helped.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...