usb problems

By etones
Aug 12, 2005
  1. im having problems with my usb ports. i was using my pc earlier today and the usb ports failed or something because my usb speedtouch modem, optical mouse and my usb hard drive went off all at the same time. and they still wont work. when i plug my modem in the lights on the front the modem flash for 2 seconds then go off again. and the hard drive dosent do anything when i plug it in. help
  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    perpahs the usb controller finally went bad on you. the attached perhiperals may have drawn too much current...
  3. etones

    etones TS Rookie Topic Starter Posts: 146

    having more problems i turned it on 2day the keyboard, my old mouse nonusb and printer arnt working now. the computer still works ok but i have nothing to control it with.
  4. bamajack69

    bamajack69 TS Rookie

    USB keyboard

    Hello, I have CP and us a special keyboard called LOMAK. It is laser activated. My pblm is the usb will not work unless u unplug &
    plug it back in and I cannot use my hands. Help.
  5. almcneil

    almcneil TS Guru Posts: 1,277

    If this hapened out of the blue, it's either a hardware issue or spyware/virus.

    Can you run scans? If so, do that first. For spyware I recommend the following 3 anti-spyware utilities:

    • Ad-Aware 2007
    • Spybot Search & Destroy
    • AVG Anti-Spyware
  6. CCT

    CCT TS Evangelist Posts: 2,653   +6

    In Device Manager, look at the USB Serial Bus Controllers section and check that the properties on ALL Root Hubs have the Power Management set so the box for allowing the computer to turn of the connected device (ie, that hub) to save power is disabled (in other words, DO NOT CHECK THE BOX OFFERED BUT UNCHECK IT IF IT IS CHECKED).

    try that anyway

  7. bamajack69

    bamajack69 TS Rookie

    I looked where you said and all it had refresh.
  8. CCT

    CCT TS Evangelist Posts: 2,653   +6

    My advice was for Win XP - that's how mine show.

    Oh well.
  9. almcneil

    almcneil TS Guru Posts: 1,277

    Did you try Safe Mode? Does you USB then work there?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...