Video card help

By Btrad
Oct 15, 2007
  1. I dont know why but my video card seems very slow, yet it should'nt I have a 7900 nvidia video card and runs about the same as my 7300 did. I was talking with my friends and they said it seemed slow as he played Unreal tournament 2007 demo and he said he got 75 average fps yet im stuck at 35-45fps and lower. Even thought my computer is 2 times better than his?

    He has

    FX 5900 nvidia
    20gig HD
    AMD 2500+

    I Have

    7900 nvidia
    2gig ram
    250gb S-ata II HD
    AMD 4200+ dual core

    I noticed before I upgraded my cpu that setting the video to lower graphics did not work at all it stayed the same? I even had it set to 320-200 resolution and still recieved 28-45 fps. I don't know whats wrong but it seems wierd that some one with a slower computer is having more performance.
  2. Rik

    Rik Banned Posts: 3,814

    Did you uninstall the driver and all software for your old card?

    Also, make sure all your mobo drivers are up to date.
  3. Btrad

    Btrad TS Rookie Topic Starter

    yes, all drivers have been uninstalled and reinstalled.
  4. pdyckman@comcas

    pdyckman@comcas TS Rookie Posts: 527

    You might try other games and take a look at your FPS.
  5. Rik

    Rik Banned Posts: 3,814

    Had a look in safe mode for redundant graphics drivers?
  6. Btrad

    Btrad TS Rookie Topic Starter

    yes i have tried splinter cell double agent and got 22 fps max of 35fps.

    is it possible for it to run in 8x mode some how instead of 16x mode ??
  7. Btrad

    Btrad TS Rookie Topic Starter


    now after i installed new cpu it lags all games, i did a format and installed new drivers from this site using 168.41 <--close to that now it keeps skipping on all my games so I got an 91.25 driver and that fixed the skipping but now my fps is really low with 30fps on a game I used to play with 125fps not cool.
  8. Rik

    Rik Banned Posts: 3,814

    Try clearing the cmos, your mobo manual will tell you how to do it.
  9. Btrad

    Btrad TS Rookie Topic Starter

    I found out why the games skipped, I needed to get a syncronizer program from AMD's website which fixed the problem. Although I still can't figure out why it's still running slower than I expected it to.
  10. Btrad

    Btrad TS Rookie Topic Starter

    I just noticed that the game still lags.. 30fps the requirements for this game are

    600 MHz CPU, 128 MB RAM, 32 MB OpenGL graphics card, 56.6k Modem/LAN
    and im only getting 30fps. (Enemy Territory)

    ---> how would I do cmos?
  11. Rik

    Rik Banned Posts: 3,814

    Read your mobo manual as i suggested before.
  12. Btrad

    Btrad TS Rookie Topic Starter

    i did the cmos and set it to default. I tryed the game again, no good. it would drop to 20-80fps, before this i had it maxed at 80fps but now it cannot keep a steady fps.
  13. Btrad

    Btrad TS Rookie Topic Starter

    I did do the cmos and set it to default,
    still doesnt work. I still get poor fps.
  14. Rik

    Rik Banned Posts: 3,814

    If its an older game then perhaps it doesn't like dual core. I believe its possible to disable one. Give that a try, probably via bios.

    I have a single core so I'm not sure on that.
  15. Maladjusted

    Maladjusted TS Rookie

    Could be the video card itself. You culd try swapping it out with another PCIe card and see if you get better frame rates. At least that way you rule out any problems with other compnents in your system.
  16. MMDominator88

    MMDominator88 TS Rookie Posts: 119

    in order to disable one of the cores on your dual-core processor, start the game then alt-tab out of the game, bring up the task manager then go to the process tab and right click on your games' process and go to set affinity and untick the "CPU 1" tick and go back into the game now, and see how that works
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...