video won't come on

By bkd39
May 10, 2005
Topic Status:
Not open for further replies.
  1. I installed a new mobo, installed video card, and monitor is not coming on. what could the problem be ?
  2. teztina

    teztina Newcomer, in training Posts: 24

    did u try reinstalling....u might have done it wrong....and did u check that the new video card is capatible with ur pc?
  3. zephead

    zephead TechSpot Paladin Posts: 2,483

    you probably missed something important. post more details about the parts themselves, your power supply, and any other parts you're dealing with.
  4. bkd39

    bkd39 Newcomer, in training Topic Starter

    it was a brand new case with a 450 watt power supply, pentium 4 cpu, brand new mobo and pci video card
  5. zephead

    zephead TechSpot Paladin Posts: 2,483

    how much prior experience do you have with computer hardware? there are multitudes of possible problems that would cause no video to be displayed.
  6. bkd39

    bkd39 Newcomer, in training Topic Starter

    I've been doing this for a couple of years now and I never had this problem. I'm starting to think may the board is bad
  7. Masque

    Masque TechSpot Chancellor Posts: 1,212

    Did you plug the 4-pin power plug to the motherboard for powering your P4 processor?
  8. bkd39

    bkd39 Newcomer, in training Topic Starter

    yes, I did that
  9. zephead

    zephead TechSpot Paladin Posts: 2,483

    if you want help you'd better post your parts' info.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.