TechSpot

Vista: Folders View cannot be managed

By tepeco
Dec 7, 2008
  1. My PC has Vista Home Premium and I have from the beginning (2 years ago), set everything to a classic view. I removed the very pretty 3-d "bubbly" look, what ever that's called, and I set ALL folders to open with a LIST view. I like simplicity! This has worked perfectly up until recently when all my folders started opening in the TILE view instead of the LIST view, as I set all folders to use, back at the beginning. There is no human error here. I didn't reset anything and I'm the only one that has access to this machine, but I suspect that some windows update has made this change for me. My machine is only allowed to do the updates that I allow and I only allow what I think are security updates and updates that are listed as critical. I have done the SP3 update. This is driving me nuts! I've tried to freeze these settings again and even gone through the start/windows programs settings to make this condition permanent, but with no luck.

    I work with many, many images in folders and lists help me see hundreds at once instead of 40 or 50 at once. I work with numbers and don't need the pretty but space gobbling details and thumbnail views. How can I get this computer to stay with my choice?
     
  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    I guess you mean SP1? There's no SP3 for Vista.

    Anyway, there is a registry key that stops Vista from changing the folder view based on its contents.

    Run regedt32, then navigate to
    HKEY_CURRENT_USER \ Software \ Classes \ Local Settings \ Software \ Microsoft \ Windows \ Shell \ Bags.

    Create a new key called AllFolders. Go to that key.

    Under AllFolders, create a new key called Shell.

    Under Shell, create a new String value called FolderType.

    Doubleclick it and set its data as NotSpecified.

    In plain English you're telling Vista to treat all (not yet recognized) folders as "All Items" view.
     
  3. SAVAGExCHAOS

    SAVAGExCHAOS TS Rookie

    ok. click on the vista pearl and click computer. press "alt" then choose "view" there you may select list or any other view that suites you. now after you have chosen a view hit "alt" (to bring back the menu bar) and choose "tools > folder options," now click the "view" tab and click the "apply to all folders" button. that should work. if not then you can extract explorer.exe from your vista installation DVD and replace the one in your windows directory. of course you cannot do this when the computer is running because explorer.exe will be in use.
     
  4. tepeco

    tepeco TS Member Topic Starter Posts: 65

    Yes, SP1 it is. I use too many different operating systems, get confused!!! Thank you both for the answers. My machine is at my office. I will apply the proper suggestions and see what happens. Thanks again!
     
  5. tepeco

    tepeco TS Member Topic Starter Posts: 65

    Mictlantecuhtli : Tried your method and wasn't exactly clear on where to create the new key. At what level?? Is there a way to make that more clear?

    SAVAGExCHAOS: I did click on the Windows Pearl, there was no choice for "computer". I have vista home premium, 32, if that helps any. I couldn't go any further with your suggestion.
     
  6. tepeco

    tepeco TS Member Topic Starter Posts: 65

    Solution in hand

    I posted my problem on a couple of different boards. I was given the following link and it resulted in what appears to be a successful fix. I followed the steps it gave and now my folders are keeping my settings to LIST. I'm hoping this will be a permanent thing.

    Here's the link for those that are following this thread.

    http://www.vistax64.com/tutorials/70819-windows-explorer-folder-view-settings.html

    Thanks again for your help.

    tepeco
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...