W32TIME not updating system clock

By Ubtree
Apr 20, 2008
  1. I have configured W32TIME:
    • Using setsntp, I specified the following time server: (, NCAR, Boulder, Colorado). The command was confirmed successful.
    • I pinged the server to confirm that it was available.
    • I also tried alternative servers.
    • I stopped and restarted the W32TIME service.
    • I checked the Event Viewer, which showed that the W32TIME service had been stopped and restarted, and reported no errors.
    • I disabled my firewall.
    Despite this, W32TIME is not updating the system clock.

    Can anyone suggest what I can try next to try to get the system clock to update automatically?
  2. raybay

    raybay TS Evangelist Posts: 7,241   +9

    Try one of the good and simple time services such as TClockEx
  3. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    This has worked for many of us:

    Right click on the clock> Adjust Date/Time> Time Zone tab> make sure you correct Time Zone is set> check 'automatically adjust for Daylight Savings Time'> Internet Time tab> Check 'automatically adjust with an internet server'> Copy this server and paste it in the Server box:

    Then click on Update now. This has set the correct time in the absence of the Windows Update or other servers working. Give it a try.
  4. Ubtree

    Ubtree TS Rookie Topic Starter

    I didn't think that TClockEx had a synchronization option, but I will look at other 3rd party alternatives.

    Many thanks for the suggestion. I have now tried it, but get the response "An error occurred getting the status of the last synchroniization. The RPC server is unavailable".
  5. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    See if this suggestion will help:
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...