TechSpot

WD 500GB USB HD not appearing in Windows Explorer

By Jake25
Feb 25, 2014
Post New Reply
  1. MY WD 500GB USB HD just yesterday stopped working normally, it was working fine two days ago. When I connect the drive via USB it appears as a different drive letter for some reason Local Disk : I then disappears. My laptop makes two noises one that I've connected a device to the laptop then another noise which is when I disconnect a device. It makes this connection/disconnection noise when the HD is plugged in numerous times every minute or so.

    The HD doesn't appear in windows explorer but appears in devices.

    Very strange and unusual any ideas?
     
  2. Jake25

    Jake25 TS Rookie Topic Starter Posts: 40

    Can anyone assist??
     
  3. Philip Booth

    Philip Booth TS Member Posts: 18

    Are you checked the hard drive in another laptop or PC? If it detects same problem, need assistance of an expert.
     
  4. Jake25

    Jake25 TS Rookie Topic Starter Posts: 40

    No but I will as I have another laptop. I'll do that now and post back shortly.
     
  5. Jake25

    Jake25 TS Rookie Topic Starter Posts: 40

    It appears on my other laptop but is inaccessible saying that the drive parameter is incorrect. It appears as D drive on my old laptop and I drive on my current laptop.
     
  6. Jake25

    Jake25 TS Rookie Topic Starter Posts: 40

    I can have it looked at by a data recovery expert but I am wondering if anyone can assist me to get it working? I believe this issue is correctable.

    In Devices and Printers it states:

    Unknown USB Device (Device Descriptor Request Failed)

    Status : Driver Error
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.