TechSpot

WD My Book 4tb External USB Crashed

By Jeni980
Sep 2, 2014
Post New Reply
  1. Hi, My first post here :)

    I really need some help I purchased a new WD My Book 4tb and have all my videos and pictures on this drive - I have always disconnected the drive properly but tonight when I connected to the laptop I get the following message;

    [​IMG]

    I cant access the drive to see if any of the files are there or not :(

    I have not done anything other than click on the drive yet as I don't want to do anything wrong :) I have so much on here I don't want to lose. Thanks :)(y)
     
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,690   +334

    You've already messed up by keeping only 1 copy of important files :/

    Is H the typical drive letter designation for that drive? I assume it is what you expected since you tried to open it. Can you take a screenshot of what Disk Management looks like with the drive on and connected?

    Have you tried a different USB cable or tried it on a different computer?
     
  3. Jeni980

    Jeni980 TS Rookie Topic Starter

    I know I have another drive I was hoping to create a backup on just not had the time yet. I don't know much about computers so be gentle with me haha:)

    Is this was you mean?

    [​IMG]
     
  4. Jeni980

    Jeni980 TS Rookie Topic Starter

    The little blue calculating circle just keeps going round though - and if I click on the drive or anything the program turns into "Not Responding" :(

    * Thanks for responding btw ;-) *
     
  5. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,690   +334

  6. Jeni980

    Jeni980 TS Rookie Topic Starter

    Thanks - I will give this a go tonight :)
     
  7. Jeni980

    Jeni980 TS Rookie Topic Starter

    Thanks for the help but every time I plug the drive in all programs turn to "not responding" until I unplug the drive....not sure what to do :-(
     
  8. Jeni980

    Jeni980 TS Rookie Topic Starter

    "unsupported"[​IMG]
     
  9. Jeni980

    Jeni980 TS Rookie Topic Starter

    This one has found it so running a superscan....hopefully this helps :)
    [​IMG]
     
  10. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,690   +334

    Right, because you can't recover to the disk you are trying to recover.
     
  11. dev667

    dev667 TS Rookie

    From the disk management screenshot, it looks like the partition doesn't have a mount point, have you tried simply assigning a drive letter to that partition?
     
     
  12. Techpumpkin_WD

    Techpumpkin_WD TS Rookie Posts: 16

    Hello there,

    I will double the suggestion to try and assign a drive letter to the volume. If that doesn't help you should try partition recovery software as suggested by SNGX1275. And definitely try with a different computer if you haven't yet. Hope you get this sorted.
     
  13. tipstir

    tipstir TS Ambassador Posts: 4,754   +96

    Take that HDD out of the WD MY BOOK and get yourself USB adapter with psu (these come with everything you need) for the HDD this way you don't need drivers for such a device. This is the only way to get into that HDD and transfer all your data to another HDD that working and not starting to fail on you. That's what happening in your case. I use NAS here! I did have what you have and took it right back to the store for a full refund.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.